DescriptionJens Kretschmer
2019-09-03 07:52:54 UTC
Description of problem:
Currently it's not possible to install qt-creator on a RHEL 7.7 system. RHEL 7.7 provides Qt 5.9.7, but qt-creator requires Qt 5.9.2.
Version-Release number of selected component (if applicable):
qt-creator-4.1.0-4.el7.x86_64
How reproducible:
always reproducible
Steps to Reproduce:
1.add EPEL repository on a RHEL 7.7 system
2.yum install qt-creator
Actual results:
--> Running transaction check
---> Package qt-creator.x86_64 0:4.1.0-4.el7 will be installed
--> Processing Dependency: qt5-qtbase(x86-64) = 5.9.2 for package: qt-creator-4.1.0-4.el7.x86_64
--> Processing Dependency: qt-creator-data = 4.1.0-4.el7 for package: qt-creator-4.1.0-4.el7.x86_64
--> Processing Dependency: libQt5WebKitWidgets.so.5(Qt_5)(64bit) for package: qt-creator-4.1.0-4.el7.x86_64
--> Processing Dependency: libQt5WebKitWidgets.so.5()(64bit) for package: qt-creator-4.1.0-4.el7.x86_64
--> Processing Dependency: libQt5WebKit.so.5()(64bit) for package: qt-creator-4.1.0-4.el7.x86_64
--> Running transaction check
---> Package qt-creator.x86_64 0:4.1.0-4.el7 will be installed
--> Processing Dependency: qt5-qtbase(x86-64) = 5.9.2 for package: qt-creator-4.1.0-4.el7.x86_64
---> Package qt-creator-data.noarch 0:4.1.0-4.el7 will be installed
---> Package qt5-qtwebkit.x86_64 0:5.9.1-2.el7 will be installed
--> Processing Dependency: libQt5WebChannel.so.5(Qt_5)(64bit) for package: qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: libQt5WebChannel.so.5()(64bit) for package: qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Running transaction check
---> Package qt-creator.x86_64 0:4.1.0-4.el7 will be installed
--> Processing Dependency: qt5-qtbase(x86-64) = 5.9.2 for package: qt-creator-4.1.0-4.el7.x86_64
---> Package qt5-qtwebchannel.x86_64 0:5.9.7-1.el7 will be installed
--> Finished Dependency Resolution
Error: Package: qt-creator-4.1.0-4.el7.x86_64 (epel)
Requires: qt5-qtbase(x86-64) = 5.9.2
Installed: qt5-qtbase-5.9.7-2.el7.x86_64 (@anaconda/7.7)
qt5-qtbase(x86-64) = 5.9.7-2.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Expected results:
qt-creator is installed successfully
Additional info:
This may be obvious, but the old build causes problems for people upgrading from 7.6 to 7.7. It would be good to have qt-creator built against 7.7 so that we could point users to a new build of qt-creator, instead of providing ugly workarounds for the upgrade issue.
Description of problem: Currently it's not possible to install qt-creator on a RHEL 7.7 system. RHEL 7.7 provides Qt 5.9.7, but qt-creator requires Qt 5.9.2. Version-Release number of selected component (if applicable): qt-creator-4.1.0-4.el7.x86_64 How reproducible: always reproducible Steps to Reproduce: 1.add EPEL repository on a RHEL 7.7 system 2.yum install qt-creator Actual results: --> Running transaction check ---> Package qt-creator.x86_64 0:4.1.0-4.el7 will be installed --> Processing Dependency: qt5-qtbase(x86-64) = 5.9.2 for package: qt-creator-4.1.0-4.el7.x86_64 --> Processing Dependency: qt-creator-data = 4.1.0-4.el7 for package: qt-creator-4.1.0-4.el7.x86_64 --> Processing Dependency: libQt5WebKitWidgets.so.5(Qt_5)(64bit) for package: qt-creator-4.1.0-4.el7.x86_64 --> Processing Dependency: libQt5WebKitWidgets.so.5()(64bit) for package: qt-creator-4.1.0-4.el7.x86_64 --> Processing Dependency: libQt5WebKit.so.5()(64bit) for package: qt-creator-4.1.0-4.el7.x86_64 --> Running transaction check ---> Package qt-creator.x86_64 0:4.1.0-4.el7 will be installed --> Processing Dependency: qt5-qtbase(x86-64) = 5.9.2 for package: qt-creator-4.1.0-4.el7.x86_64 ---> Package qt-creator-data.noarch 0:4.1.0-4.el7 will be installed ---> Package qt5-qtwebkit.x86_64 0:5.9.1-2.el7 will be installed --> Processing Dependency: libQt5WebChannel.so.5(Qt_5)(64bit) for package: qt5-qtwebkit-5.9.1-2.el7.x86_64 --> Processing Dependency: libQt5WebChannel.so.5()(64bit) for package: qt5-qtwebkit-5.9.1-2.el7.x86_64 --> Running transaction check ---> Package qt-creator.x86_64 0:4.1.0-4.el7 will be installed --> Processing Dependency: qt5-qtbase(x86-64) = 5.9.2 for package: qt-creator-4.1.0-4.el7.x86_64 ---> Package qt5-qtwebchannel.x86_64 0:5.9.7-1.el7 will be installed --> Finished Dependency Resolution Error: Package: qt-creator-4.1.0-4.el7.x86_64 (epel) Requires: qt5-qtbase(x86-64) = 5.9.2 Installed: qt5-qtbase-5.9.7-2.el7.x86_64 (@anaconda/7.7) qt5-qtbase(x86-64) = 5.9.7-2.el7 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest Expected results: qt-creator is installed successfully Additional info: