Bug 1748418

Summary: python-flask-migrate: Remove (sub)packages from Fedora 32+: python2-flask-migrate
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: python-flask-migrateAssignee: Itamar Reis Peixoto <itamar>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: cstratak, igor.raits, itamar, lbalhar, mhroncok, ngompa13, pviktori, rbean, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-flask-migrate-2.1.1-7.fc32 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-10 11:16:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1625773, 1690439, 1698500    

Description Miro Hrončok 2019-09-03 14:32:59 UTC
In line with the Mass Python 2 Package Removal [0], the following (sub)packages of python-flask-migrate were marked for removal:

 * python2-flask-migrate

According to our query, those (sub)packages only provide a Python 2 importable module. If this is not true, please tell us why, so we can fix our query.

Please remove them from your package in Rawhide (Fedora 32).

Please don't remove packages from Fedora 31, it is past Beta Freeze.
Please don't do this for Fedora 30/29 either, removing packages from a released Fedora branch is forbidden.

As said in the change document, if there is no objection in a week, we will remove the package(s) as soon as we get to it. This change might not match your packaging style, so we'd prefer if you did the change. If you need more time, please let us know here.

If you do the change yourself, it would help us a lot by reducing the amount of packages we need to mass change.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

[0] https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal

Comment 1 Miro Hrončok 2019-09-03 14:33:20 UTC
*** Bug 1745068 has been marked as a duplicate of this bug. ***

Comment 2 Miro Hrončok 2019-09-10 10:59:34 UTC
python2-flask-migrate-2.1.1-6.fc32.noarch fails to install in Fedora rawhide:

  nothing provides python2-flask-script needed by python2-flask-migrate-2.1.1-6.fc32.noarch

python3-flask-migrate-2.1.1-6.fc32.noarch fails to install in Fedora rawhide:

  nothing provides python3-flask-script needed by python3-flask-migrate-2.1.1-6.fc32.noarch

This is caused by the dependency that was retired (python-flask-script).

Please drop the dependency, unretire the dependency or remove the package entirely. Thanks

Comment 3 Miro Hrončok 2019-09-10 11:04:20 UTC
I cannot remove the python2 subpackage because of missing python3 package:

DEBUG util.py:585:  BUILDSTDERR: No matching package to install: 'python3-flask-script'
DEBUG util.py:585:  BUILDSTDERR: Not all dependencies satisfied
DEBUG util.py:585:  BUILDSTDERR: Error: Some packages could not be found.

But since the %check is skipped anyway, I'll remove the build dependency. That said, the resulting python3 package won't install anyway.