Bug 1749155

Summary: bug-1402841.t-mt-dir-scan-race.t fails spuriously
Product: [Community] GlusterFS Reporter: Ravishankar N <ravishankar>
Component: replicateAssignee: Ravishankar N <ravishankar>
Status: CLOSED NEXTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 7CC: bugs
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1748744 Environment:
Last Closed: 2019-09-05 12:21:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1748744, 1749157, 1807748    
Bug Blocks:    

Description Ravishankar N 2019-09-05 04:00:18 UTC
+++ This bug was initially created as a clone of Bug #1748744 +++

Description of problem:


    Since commit 600ba94183333c4af9b4a09616690994fd528478, shd starts
    healing as soon is it is toggled from disabled to enabled. This was
    causing the following line in the .t to fail on a 'fast' machine (always
    on my laptop and sometimes on the jenkins slaves).

    EXPECT_NOT "^0$" get_pending_heal_count $V0

    because by the time shd was disabled, the heal was already completed.

--- Additional comment from Worker Ant on 2019-09-04 06:08:55 UTC ---

REVIEW: https://review.gluster.org/23352 (tests: fix spurious failure of bug-1402841.t-mt-dir-scan-race.t) posted (#1) for review on master by Ravishankar N

--- Additional comment from Ravishankar N on 2019-09-04 06:13:40 UTC ---

Forgot to add the links to failures in the bug description:
https://build.gluster.org/job/centos7-regression/7743/
https://build.gluster.org/job/centos7-regression/7747/

--- Additional comment from Worker Ant on 2019-09-04 18:29:05 UTC ---

REVIEW: https://review.gluster.org/23352 (tests: fix spurious failure of bug-1402841.t-mt-dir-scan-race.t) merged (#3) on master by Raghavendra Talur

Comment 1 Worker Ant 2019-09-05 04:03:27 UTC
REVIEW: https://review.gluster.org/23357 (tests: fix spurious failure of bug-1402841.t-mt-dir-scan-race.t) posted (#1) for review on release-7 by Ravishankar N

Comment 2 Worker Ant 2019-09-05 12:21:36 UTC
REVIEW: https://review.gluster.org/23357 (tests: fix spurious failure of bug-1402841.t-mt-dir-scan-race.t) merged (#1) on release-7 by Ravishankar N