Bug 1751007

Summary: Backups does not check backup name after 2nd check
Product: Red Hat Directory Server Reporter: Anuj Borah <aborah>
Component: cockpit-389-dsAssignee: mreynolds
Status: CLOSED ERRATA QA Contact: RHDS QE <ds-qe-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 11.0CC: afarley, lkrispen, mhonek, pasik, spichugi, tbordaz, vashirov
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 389-ds-base-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-11-06 12:42:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Video1 none

Description Anuj Borah 2019-09-11 03:05:15 UTC
Created attachment 1613880 [details]
Video1

Description of problem:

Database > Backups & LDIFS > Backups

Create backup with same name 3 times

Version-Release number of selected component (if applicable):

389-ds-base-1.4.1.8-1.module+el8dsrv+4209+f45880df.x86_64

How reproducible:
Always 


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Viktor Ashirov 2019-10-29 20:58:12 UTC
Builds tested:
389-ds-base-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6.x86_64
cockpit-389-ds-1.4.1.9-1.module+el8dsrv+4243+ba0eb3c6.noarch

Second backup with the same name saves the previous backup with .bak extension. And the third backup with the same name shifts the backups by one, i.e.:
test.bak -> /dev/null
test -> test.bak

Marking as VERIFIED.

Comment 4 errata-xmlrpc 2019-11-06 12:42:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:3731