Bug 1753955

Summary: description of public_hosted_zone in /etc/ovirt-engine-metrics/config.yml.d/metrics-store-config.yml
Product: Red Hat Enterprise Virtualization Manager Reporter: Olimp Bockowski <obockows>
Component: ovirt-engine-metricsAssignee: Shirly Radco <sradco>
Status: CLOSED ERRATA QA Contact: Guilherme Santos <gdeolive>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.3.5CC: lleistne, pelauter
Target Milestone: ovirt-4.3.7Keywords: ZStream
Target Release: 4.3.7   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: ovirt-engine-metrics-1.3.5.1 Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-12-12 10:36:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Metrics RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1767344    

Description Olimp Bockowski 2019-09-20 11:13:23 UTC
Description of problem:
There should be a much better description of public_hosted_zone  in /etc/ovirt-engine-metrics/config.yml.d/metrics-store-config.yml

Version-Release number of selected component (if applicable):
Name        : ovirt-engine-metrics
Version     : 1.3.3.3

Additional info:

Now there is only 
# DNS zone (format: example.com) of the Metrics Store virtual machines
public_hosted_zone: 

According to the feedback from GSS it looks like this parameter isn't clear enough. It should be explained what is the purpose and where is has to point out (e.g. it will be master0 that in all in one OCP VM)

Comment 2 Guilherme Santos 2019-11-15 14:48:23 UTC
Verified on:
ovirt-engine-metrics-1.3.5.1-1.el7ev.noarch

Description of public_hosted_zone seems more completed and contains an example of its use:

## The DNS zone of the Metrics Store virtual machines. No default.
# For example:
# If public_hosted_zone: example.com, then 1st master metrics store VM address will be set to `master0.example.com`.
# All metrics and logs will be sent to these VMs.

Comment 4 errata-xmlrpc 2019-12-12 10:36:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4229