Bug 1754364

Summary: Dependency rdma-core breaks kernell install on aarch64, needs dep on pciutils for dracut
Product: [Fedora] Fedora Reporter: Warren Togami <wtogami>
Component: rdma-coreAssignee: Honggang LI <honli>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 31CC: amit, berrange, cfergeau, crobinso, dledford, dwmw2, honli, itamar, jarodwilson, pbonzini, rjones, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: aarch64   
OS: Unspecified   
Whiteboard:
Fixed In Version: rdma-core-20.1-5.fc31 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-12-05 01:40:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 245418    

Description Warren Togami 2019-09-23 03:46:52 UTC
qemu-system-aarch64-core-4.1.0-1.fc31.aarch64 requires libibverbs-20.1-4.fc31.aarch64 and librdmacm-20.1-4.fc31.aarch64 and libibumad-20.1-4.fc31.aarch64.

Those three libraries require rdma-core-20.1-4.fc31.aarch64 which contains /usr/lib/dracut/modules.d/05rdma

Updating / installing...
   1:kernel-core-5.3.0-1.fc31         ################################# [ 33%]
   2:kernel-modules-5.3.0-1.fc31      ################################# [ 67%]
   3:kernel-5.3.0-1.fc31              ################################# [100%]
dracut: Disabling early microcode, because kernel does not support it. CONFIG_MICROCODE_[AMD|INTEL]!=y
dracut-install: ERROR: installing 'lspci'
dracut-install: ERROR: installing 'setpci'
dracut: FAILED: /usr/lib/dracut/dracut-install -D /var/tmp/dracut.TIvrLm/initramfs -a lspci setpci awk sleep


aarch64 does not normally install package pciutils which contains lspci and setpci.

Proposed Fixes:
* rdma-core must require pciutils to avoid breaking dracut
* Does qemu really need to install these rarely used Inifiband dependencies? Maybe make it into a weak dependency instead?

Comment 1 Cole Robinson 2019-09-24 16:24:02 UTC
qemu links against the rdma libraries so it's not really optional. some pieces of qemu are modularized and shipped as their own .so, but all bits that use rdma aren't one of them AFAICT.

Like you say, the fix here is for rdma-core to require pciutils, so reassigning

Comment 2 Fedora Update System 2019-11-29 00:56:21 UTC
FEDORA-2019-668ca01941 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-668ca01941

Comment 3 Fedora Update System 2019-11-30 01:19:40 UTC
rdma-core-20.1-5.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-668ca01941

Comment 4 Fedora Update System 2019-12-05 01:40:47 UTC
rdma-core-20.1-5.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.