Bug 1754955

Summary: python-jinja2: Remove (sub)packages from Fedora 32+: python2-jinja2
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: python-jinja2Assignee: Thomas Moschny <thomas.moschny>
Status: CLOSED CANTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: anto.trande, cstratak, djc, ewalsh, greg.hellings, igor.raits, lewk, mhroncok, ngompa13, orion, pj.pandit, pviktori, thomas.moschny, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-11-03 11:53:51 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1736904, 1737930, 1741793    
Bug Blocks: 1625773, 1698500    

Description Miro Hrončok 2019-09-24 12:37:30 UTC
In line with the Mass Python 2 Package Removal [0], the following (sub)packages of python-jinja2 were marked for removal:

 * python2-jinja2

According to our query, those (sub)packages only provide a Python 2 importable module. If this is not true, please tell us why, so we can fix our query.

Please remove them from your package in Rawhide (Fedora 32).

Please don't remove packages from Fedora 31, it is past Beta Freeze.
Please don't do this for Fedora 30/29 either, removing packages from a released Fedora branch is forbidden.

As said in the change document, if there is no objection in a week, we will remove the package(s) as soon as we get to it. This change might not match your packaging style, so we'd prefer if you did the change. If you need more time, please let us know here.

If you do the change yourself, it would help us a lot by reducing the amount of packages we need to mass change.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

[0] https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal

Comment 1 Miro Hrončok 2019-09-24 12:41:32 UTC
Note that python2-jinja2 is still needed to:

 - run beaker (already doesn't install)
 - build seqan2 (has a bcond that can disable that dependency)
 - build termy-qt (already fails to build due to some Python 2 problems)

I'll CC the maintainers of those packages to see if they mind if we drop python2-jinja2.

Comment 2 greg.hellings 2019-09-26 17:17:59 UTC
I have test builds for beaker against Python 3 going out now.

Comment 3 Miro Hrončok 2019-09-30 14:24:52 UTC
Eamon, can we drop python2-jinja2?

Comment 4 Miro Hrončok 2019-10-01 14:56:36 UTC
python2-jinja2 is still needed by trac, see bz1737930.

Comment 5 Eamon Walsh 2019-10-02 20:53:52 UTC
(In reply to Miro Hrončok from comment #3)
> Eamon, can we drop python2-jinja2?

You can drop it.

The Python 2 issues in termy-qt are all related to the bundled V8 library build process. Gonna try and get this sorted out soon, but you don't need to wait on me.

Comment 6 Miro Hrončok 2019-11-03 11:53:51 UTC
trac will likely get an exception and will keep pulling this in.