Bug 1755721

Summary: Unable to start the release job
Product: [Community] GlusterFS Reporter: Rinku <rkothiya>
Component: project-infrastructureAssignee: bugs <bugs>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: urgent Docs Contact:
Priority: unspecified    
Version: mainlineCC: bugs, dkhandel, gluster-infra, hgowtham, mscherer
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1731067 Environment:
Last Closed: 2020-02-17 17:35:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1731067    
Bug Blocks:    
Attachments:
Description Flags
screenshot of the new-release job
none
Permission issue screenshot during build none

Description Rinku 2019-09-26 06:45:19 UTC
After tagging the release-7 with rc2 I wanted to start the release job, but I am unable to see "build with parameters" there. 

Usually after tagging the release candidate, I do the following : 

1) I go to this website and login.
   https://build.gluster.org/job/release-new/

2) Clicked on the "Release-new" menu
3) Then clicked on the "build with parameters"

However this time I do not see any option "build with parameters".

Comment 1 Deepshikha khandelwal 2019-09-26 07:35:27 UTC
What's you github handle?

Comment 2 Deepshikha khandelwal 2019-09-26 08:45:14 UTC
I fixed it.
Let me know if you still face the same issue.

Comment 3 Rinku 2019-09-26 13:41:19 UTC
I am still facing problem. still can't see "build with parameters".

Comment 4 M. Scherer 2019-09-27 08:46:50 UTC
I am removing "private" setting, there is nothing private there.

Comment 5 M. Scherer 2019-09-27 08:50:40 UTC
could we get a screenshot of what it look like on your side ? Do you get more item from the menu than what you get on another job, or is everything the same ?

Comment 6 Deepshikha khandelwal 2019-09-27 08:56:10 UTC
Can you please also provide the screenshot of what you can see for release-new job. That would be helpful to identify the issue.

Comment 7 hari gowtham 2019-09-27 09:26:16 UTC
Created attachment 1619976 [details]
screenshot of the new-release job

As requested, i have attached the screen shot of the new release page

Comment 8 M. Scherer 2019-09-27 09:49:47 UTC
ok, so 1) "jenkins, WTF". 2), what happen if you hit build ? I am trying to narrow if the problem is "display issue in the menu", or some permission problem. 

I do get the same result when I am not connected, but it ask me to login when I hit "build".

Comment 9 hari gowtham 2019-10-01 06:23:20 UTC
It is a permission problem. Have attached the screenshot for reference

Comment 10 hari gowtham 2019-10-01 06:24:34 UTC
Created attachment 1621330 [details]
Permission issue screenshot during build

The image to show that i'm getting a permission denied error when I try to build

Comment 11 Deepshikha khandelwal 2019-10-01 08:42:12 UTC
Can you please tell us the parameters for building if it's blocking you. We can trigger on your behalf.

We are currently figuring out the global security configs for the jenkins instance and it may take some time.

Comment 13 hari gowtham 2019-10-09 10:15:42 UTC
I have been currently blocked on building 5.10 as well.

The parameters are:
GERRIT_REFSPEC :  v5.10
RELEASE_VERSION:   5.10

Comment 14 Rinku 2019-10-15 05:22:08 UTC
I have been currently blocked on building 7.0 : 

The parameters are : 
GERRIT_REFSPEC :  v7.0
RELEASE_VERSION:   7.0

Comment 15 hari gowtham 2019-10-28 18:30:02 UTC
Hi Deepshikha,

I have been currently blocked on building 6.6.

The parameters are:
GERRIT_REFSPEC :  v6.6
RELEASE_VERSION:   6.6

Can you please trigger the build.

Comment 16 M. Scherer 2019-10-28 19:45:06 UTC
So I did the 6.6

Comment 17 M. Scherer 2019-10-28 19:45:33 UTC
https://build.gluster.org/job/release/215/console seems to have failed :/

Comment 18 M. Scherer 2019-10-28 19:46:39 UTC
ok triggering the proper job is better: https://build.gluster.org/job/release-new/104/

Comment 19 hari gowtham 2019-10-29 04:37:20 UTC
Thanks Misc!

Comment 20 hari gowtham 2019-12-09 11:35:09 UTC
Hi,

We need to trigger a build for 5.11

build parameters:
GERRIT_REFSPEC :  v5.11
RELEASE_VERSION:   5.11

Comment 21 Rinku 2019-12-20 13:10:59 UTC
Hi, 

We need to trigger a build for 7.1

build parameters:
GERRIT_REFSPEC :  v7.1
RELEASE_VERSION:   7.1

Regards
Rinku

Comment 22 hari gowtham 2019-12-27 07:22:43 UTC
Hi,

We need to trigger a build for 6.7

build parameters:
GERRIT_REFSPEC :  v6.7
RELEASE_VERSION:   6.7

Comment 23 M. Scherer 2020-01-02 12:34:09 UTC
Done:
https://build.gluster.org/job/release-new/107/

I will watch and restart, in case the builders are not working

Comment 24 hari gowtham 2020-01-02 13:17:40 UTC
(In reply to M. Scherer from comment #23)
> Done:
> https://build.gluster.org/job/release-new/107/
> 
> I will watch and restart, in case the builders are not working

Thanks Misc!

Comment 25 M. Scherer 2020-01-02 15:27:03 UTC
So, I gave another try at making the job work, can someone in the release engineer group on github try to see if the job is accessible ?

Comment 26 hari gowtham 2020-01-03 08:53:31 UTC
I tried it and I'm facing problems with triggering the job.
This time instead of just an access denied, its giving the below output.

HTTP ERROR 403 Problem accessing //job/release-new/build. Reason: No valid crumb was included in the request

Comment 27 Rinku 2020-01-15 10:45:46 UTC
Hi, 

We need to trigger a build for 7.2

build parameters:
GERRIT_REFSPEC :  v7.2
RELEASE_VERSION:   7.2

Regards
Rinku

Comment 28 M. Scherer 2020-01-22 15:46:55 UTC
Ok so thanks to Deepshika and I being in the same room at the same time, we were able to fiddle with jenkins configuration and this issue should now be solved (seems "build with parameters" requires "build" + "configure", because parameters are likely some form of configuration...). 

Can you tell me if the button appear for you ?

I also added hari who was not in the right group for access to release engineering jobs. 

Can you confirm this work fine now ?

Comment 29 M. Scherer 2020-01-27 16:28:35 UTC
So this didn't work, but if we add a individual user, this work. So the group name is likely wrong, we will investigate. in the mean time, the access should be ok now.

Comment 30 Rinku 2020-02-17 12:28:23 UTC
Hi, 

We need to trigger a build for 7.3

build parameters:
GERRIT_REFSPEC :  v7.3
RELEASE_VERSION:   7.3

Regards
Rinku

Comment 31 M. Scherer 2020-02-17 12:52:45 UTC
isn't it now in self service ?

Comment 32 Deepshikha khandelwal 2020-02-17 17:35:07 UTC
Michael, Rinku wasn't able to trigger because he was not logged in and also he was trying to build with dropdown button on jenkins instance.

Closing it now as Rinku and Hari now have enough permission to start the release job.