Bug 1759880

Summary: update rules in cluster-monitoring-operator to reflect chages to container and pod metric labels
Product: OpenShift Container Platform Reporter: Paul Gier <pgier>
Component: MonitoringAssignee: Paul Gier <pgier>
Status: CLOSED ERRATA QA Contact: Junqi Zhao <juzhao>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.3.0CC: alegrand, anpicker, erooth, juzhao, kakkoyun, lcosic, mloibl, pkrupa, scuppett, surbania
Target Milestone: ---   
Target Release: 4.3.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-13 21:27:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Paul Gier 2019-10-09 10:15:14 UTC
Metrics coming from CAdvisor have had some changes to the container and pod labels.  For example, the labels "container_name" and "pod_name" in container_memory_usage_bytes have changed to "container" and "pod".

These labels need to be updated in the cluster-monitoring-operator recording rules.

Comment 1 Sergiusz Urbaniak 2019-10-11 09:49:49 UTC
bumping to medium, as we cannot ship 4.3 without this change.

Comment 2 Paul Gier 2019-10-11 13:02:13 UTC
AFAICT the scope of this is limited to just container_name and pod_name labels:
New label names were added here: https://github.com/kubernetes/kubernetes/pull/69099
and old ones were dropped here: https://github.com/kubernetes/kubernetes/pull/80376

Comment 11 errata-xmlrpc 2020-05-13 21:27:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062