Bug 1760121

Summary: what version ?
Product: [Fedora] Fedora Reporter: Mohammed Arafa <bugzilla>
Component: powertopAssignee: Jaroslav Škarvada <jskarvad>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: ajax, jskarvad, olysonek, TicoTimo
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: powertop-2.11-2.fc30 powertop-2.11-2.fc31 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-10-10 15:18:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mohammed Arafa 2019-10-09 22:11:48 UTC
Description of problem:
when running powertop as a normal user i see this

[marafa@laptop ~]$ powertop 
PowerTOP RUN-VERSION-SCRIPT-IN-GIT-REPOSITORY-ONLY must be run with root privileges.
exiting...


the issue is the `RUN-VERSION-SCRIPT-IN-GIT-REPOSITORY-ONLY` which looks to be a debug trick

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jaroslav Škarvada 2019-10-10 12:55:23 UTC
Thanks for the report, it's not only in the error message, it's everywhere :)

Comment 2 Fedora Update System 2019-10-10 15:21:55 UTC
FEDORA-2019-8bde96b364 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-8bde96b364

Comment 3 Fedora Update System 2019-10-10 15:23:37 UTC
FEDORA-2019-4ef7f90444 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4ef7f90444

Comment 4 Fedora Update System 2019-10-11 16:53:31 UTC
powertop-2.11-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-8bde96b364

Comment 5 Fedora Update System 2019-10-12 02:02:08 UTC
powertop-2.11-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4ef7f90444

Comment 6 Fedora Update System 2019-10-19 17:41:11 UTC
powertop-2.11-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2019-10-26 17:24:35 UTC
powertop-2.11-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.