Bug 1760393

Summary: Add metric cpuinfo to node_exporter to gather cpu topology/hyperthreading information in telemetry
Product: OpenShift Container Platform Reporter: Paul Gier <pgier>
Component: MonitoringAssignee: Paul Gier <pgier>
Status: CLOSED ERRATA QA Contact: Junqi Zhao <juzhao>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 4.3.0CC: alegrand, anpicker, calfonso, chambrid, erooth, jpazdziora, juzhao, kakkoyun, kgeorgie, lcosic, mloibl, pkrupa, surbania
Target Milestone: ---   
Target Release: 4.3.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1773665 (view as bug list) Environment:
Last Closed: 2020-01-23 11:07:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1773665    

Description Paul Gier 2019-10-10 12:41:28 UTC
Determining if a node has hyperthreading enabled is not possible with the currently available node_exporter metrics.  We need a new metric added to node_exporter to expose the required information.

Comment 1 Paul Gier 2019-10-10 12:44:38 UTC
The new metric has been added to upstream node_exporter in https://github.com/prometheus/node_exporter/pull/1489
And patched to openshift node_exporter in https://github.com/openshift/node_exporter/pull/33

Comment 2 Paul Gier 2019-10-10 13:36:51 UTC
PR to update CLI flag to node_exporter: https://github.com/openshift/cluster-monitoring-operator/pull/498

Comment 15 Viacheslav 2019-11-01 17:17:05 UTC
Fixed.

4.3.0-0.nightly-2019-11-01-032109

Comment 18 errata-xmlrpc 2020-01-23 11:07:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062