Bug 1760836

Summary: deploy image ignores target port drop down selection and always uses first entry
Product: OpenShift Container Platform Reporter: spathak <spathak>
Component: Dev ConsoleAssignee: cvogt
Status: CLOSED ERRATA QA Contact: Ruchir Garg <rgarg>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.2.0CC: aos-bugs, gamore, jowilson, nmukherj
Target Milestone: ---   
Target Release: 4.3.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Cause: While populating the route object for creation with necessary data, instead of setting the selected port from the target-port drop-down as the route target-port, first port from the list of available ports was being set. Consequence: User was not able to select the desired target port. Fix: Check if there is a port selected from target-port drop-down and set it as the route target-port otherwise set the first port as the route target-port. Result: Now user can select the desired target-port from the list of available ports.
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-01-23 11:07:15 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description spathak@redhat.com 2019-10-11 12:55:40 UTC
Description of problem:

The `import-submit-utils` and `deployImage-submit-utils` have diverged in logic. The `deployImage-submit-utils` ignores the targetPort selected by the user and always uses the first entry in the ports list.

Ideally, these two files should be refactored to use shared code so that changes in one flow don't go missed in the other.

Comment 2 cvogt 2019-11-23 01:26:18 UTC
Marking as verified by gamore@redhat.com
https://jira.coreos.com/browse/ODC-1911

Comment 4 errata-xmlrpc 2020-01-23 11:07:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062