Bug 1760970

Summary: EPEL7 - kstars won't install on RHEL 7.7
Product: [Fedora] Fedora EPEL Reporter: Troy Dawson <tdawson>
Component: kstarsAssignee: Christian Dersch <lupinix.fedora>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: epel7CC: astro-sig, jreznik, kde-sig, lupinix.fedora, rdieter, than
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: kstars-17.08.2-3.3.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-01-05 00:07:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1647564    

Description Troy Dawson 2019-10-11 20:37:25 UTC
Current kstars for EPEL7 (kstars-17.08.2-2.1.el7) requires
  LibRaw-0.14.8-5.el7.20120830git98d925
RHEL 7.7 has
  LibRaw-0.19.2-1.el7

Please fix this package so that it can be installed in RHEL 7.7.
If you have not responded in a week, we will have a proven packager fix it.
If you know you will not be able to get to it and would like it fixed sooner, please let us know in this bug.
If you feel this package should no longer be in EPEL7, please let us know in this bug.

Comment 1 Christian Dersch 2019-10-20 11:18:32 UTC
Tried a simple rebuild without success… As I'm quite out of time, I'm not able to fix this soon.

In file included from /usr/include/libraw/libraw.h:39:0,
                 from /builddir/build/BUILD/kstars-17.08.2/kstars/indi/indiccd.cpp:29:
/usr/include/libraw/libraw_alloc.h: In member function 'void libraw_memmgr::mem_ptr(void*)':
/usr/include/libraw/libraw_alloc.h:96:13: error: exception handling disabled, use -fexceptions to enable
       throw LIBRAW_EXCEPTION_MEMPOOL;

https://koji.fedoraproject.org/koji/taskinfo?taskID=38422180

Comment 2 Troy Dawson 2019-10-23 15:59:48 UTC
I have verified, in a mock environment, that if you downgrade just libRaw and libRaw-devel to the previous version (LibRaw-0.14.8-5.el7.20120830git98d925) then kstars builds correctly.  It fails, just as your build did, with the newer libRaw.
So, this is a matter of libRaw being newer causing the build to fail, and not some other package.

Comment 3 Troy Dawson 2019-11-08 21:06:23 UTC
I've tried several variations of updating and such, with no success.
kstars can be built without libRaw.  I know that some features will go away, but maybe it's better for some features to go away than to not have it at all.

Comment 4 Fedora Update System 2019-12-10 16:55:39 UTC
FEDORA-EPEL-2019-5f2e0924a9 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-5f2e0924a9

Comment 5 Fedora Update System 2019-12-11 17:24:42 UTC
kstars-17.08.2-3.3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-5f2e0924a9

Comment 6 Fedora Update System 2020-01-05 00:07:12 UTC
kstars-17.08.2-3.3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.