Bug 1761001

Summary: Canon CanoScan LiDE 110 is no longer detected properly using sane-backends-1.0.28-1 (REGRESSION)
Product: [Fedora] Fedora Reporter: Alex Markley <alex>
Component: sane-backendsAssignee: Nils Philippsen <nphilipp>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 30CC: bruguel, ced, kaarle.ritvanen, nphilipp, thibault.north, zdohnal
Target Milestone: ---Flags: zdohnal: needinfo? (alex)
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: sane-backends-1.0.28-4.fc30 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-10-19 17:41:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Alex Markley 2019-10-11 21:48:43 UTC
Description of problem:

Canon CanoScan LiDE 110 is no longer being detected or initialized by sane, affecting xsane, simple-scan, and others. This is a regression, previous versions interacted with the scanner no problem.


Version-Release number of selected component (if applicable):

sane-backends-1.0.28-1.fc30.x86_64 is the first version I noticed which exhibits the problem.

sane-backends-1.0.27-23.fc30.x86_64 fixes the problem, and the scanner works as usual.


How reproducible:

100%


Steps to Reproduce:
1. Install `sane-backends-1.0.28-1.fc30.x86_64`
2. Run `sudo sane-find-scanner`
3. Observe `found USB scanner (vendor=0x04a9 [Canon], product=0x1909 [CanoScan], chip=GL124) at libusb:001:006` as expected in the output.
4. Run `scanimage -L`
5. Observe, no entry for the CanoScan.


Actual results:

`scanimage -L` produces no entries for the CanoScan LiDE 110, no sane-powered utilities can detect or interact with the scanner.


Expected results:

Normally `scanimage -L` produces the following for the CanoScan: device `genesys:libusb:001:007' is a Canon LiDE 110 flatbed scanner


Additional info:

Running `sudo dnf downgrade sane-backends` provides temporary relief from this problem.

Comment 1 Philippe Troin 2019-10-12 00:51:10 UTC
Same problem with LIDE220.
Bus 003 Device 008: ID 04a9:190f Canon, Inc. CanoScan LiDE 220

Downgrading to 1.0.27-24.fc30 fixes the issue.

Comment 2 Philippe Troin 2019-10-12 05:05:45 UTC
(In reply to Philippe Troin from comment #1)
> Same problem with LIDE220.
> Bus 003 Device 008: ID 04a9:190f Canon, Inc. CanoScan LiDE 220
> 
> Downgrading to 1.0.27-24.fc30 fixes the issue.

After investigation, this is a different problem.  Please disregard comment 1.

Comment 3 Zdenek Dohnal 2019-10-14 12:42:09 UTC
Hi Alex and Philippe,

thank you for reporting the issue!

Actually it is caused by missing genesys backend as whole, who took care of this type of scanners.

Genesys backend is now written in C++11 and it cannot be built without it due settings during configure phase. Buildroot did not have gcc-c++ during build and configure produced only warning about genesys will not be created.

Adding gcc-c++ to buildrequires fixes it.

Would you mind trying this build if it fixes it? https://koji.fedoraproject.org/koji/taskinfo?taskID=38290503

Comment 4 Zdenek Dohnal 2019-10-14 13:03:04 UTC
D'oh, the build failed, wait a minute...

Comment 5 Zdenek Dohnal 2019-10-14 13:16:08 UTC
x86_64 build is ok, so it is possible for you to test.

Comment 6 ced 2019-10-16 08:51:16 UTC
Hi,

I had the same issue today (Canon LiDE 110 not detected with sane-backends-1.0.28-1 because of missing genesys driver).

Using the build you linked to:

  Upgraded:
    sane-backends-1.0.28-2.fc30.x86_64                sane-backends-libs-1.0.28-2.fc30.x86_64                sane-backends-drivers-scanners-1.0.28-2.fc30.x86_64               

genesys driver is back:

  ❯ locate genesys
  /etc/sane.d/genesys.conf
  /usr/lib64/sane/libsane-genesys.so
  /usr/lib64/sane/libsane-genesys.so.1
  /usr/lib64/sane/libsane-genesys.so.1.0.28
  /usr/share/man/man5/sane-genesys.5.gz

And the scanner is detected:

  ❯ scanimage -L
  device `genesys:libusb:001:014' is a Canon LiDE 110 flatbed scanner

But it crashes in xsane preview or scanimage test:

  ❯ scanimage --test
  Output format is not set, using pnm as a default.
  /usr/include/c++/9/bits/stl_vector.h:1042: std::vector<_Tp, _Alloc>::reference std::vector<_Tp, _Alloc>::operator[](std::vector<_Tp, _Alloc>::size_type) [with _Tp = short unsigned int; _Alloc = std::allocator<short unsigned int>; std::vector<_Tp, _Alloc>::reference = short unsigned int&; std::vector<_Tp, _Alloc>::size_type = long unsigned int]: Assertion '__builtin_expect(__n < this->size(), true)' failed.
[1]    19216 abort (core dumped)  scanimage --test

Comment 7 Zdenek Dohnal 2019-10-16 09:55:07 UTC
@ced@winkie.fr

That's the bug https://bugzilla.redhat.com/show_bug.cgi?id=1761530 , please follow discussion there.

Comment 8 Fedora Update System 2019-10-17 12:56:17 UTC
FEDORA-2019-4c80d8cf5f has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4c80d8cf5f

Comment 9 Fedora Update System 2019-10-17 23:42:17 UTC
sane-backends-1.0.28-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4c80d8cf5f

Comment 10 Fedora Update System 2019-10-18 08:52:09 UTC
FEDORA-2019-4e0ac1c8bb has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4e0ac1c8bb

Comment 11 Fedora Update System 2019-10-18 21:00:12 UTC
sane-backends-1.0.28-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4e0ac1c8bb

Comment 12 Guelfucci Bruno 2019-10-19 10:03:51 UTC
Hi, dame issue with lide 120. Problem resolved with package installation from fedora (not update) repository in 1.0.27.
Cheers,

Comment 13 Fedora Update System 2019-10-19 17:41:45 UTC
sane-backends-1.0.28-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Guelfucci Bruno 2019-10-21 18:17:39 UTC
Everything is ok with sane-backends-1.0.28-4.fc30 with lide 120. Thank you very much.

Comment 15 Kaarle Ritvanen 2019-10-21 21:28:38 UTC
Please fix this in Fedora 29 as well.

Comment 16 Zdenek Dohnal 2019-10-22 10:23:01 UTC
Kaarle,

it is already fixed for F29, but the update is still in bodhi https://bodhi.fedoraproject.org/updates/FEDORA-2019-37c002492b with no karma - so it seems nobody wants to have it fixed fast.

So there are two options:

1) you and two other people will add karma to the update and the fix will be in stable repos within days

2) you will install the fixed package by hand - either by enabling testing and installing sane-backends&friends, or get link to koji (which is in the update too) and install needed rpms by links.