Bug 1763098

Summary: Prometheus container doesn't have terminationMessagePolicy FallbackToLogsOnError
Product: OpenShift Container Platform Reporter: Pawel Krupa <pkrupa>
Component: MonitoringAssignee: Sergiusz Urbaniak <surbania>
Status: CLOSED ERRATA QA Contact: Junqi Zhao <juzhao>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.2.0CC: alegrand, anpicker, ccoleman, erooth, fbranczy, juzhao, kakkoyun, lcosic, mloibl, pkrupa, surbania
Target Milestone: ---   
Target Release: 4.2.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1762968 Environment:
Last Closed: 2020-02-24 16:52:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1762968    
Bug Blocks:    

Description Pawel Krupa 2019-10-18 09:00:43 UTC
+++ This bug was initially created as a clone of Bug #1762968 +++

While debugging a 4.2 failure I saw that prometheus had exited with exit code 1 but not reported a message.  While most of the other containers have the correct terminationMessagePolicy, Prometheus is wrong.

We need to fix and backport to 4.2 so we can correctly debug when containers exit on error.

Comment 5 errata-xmlrpc 2020-02-24 16:52:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0460