Bug 1764611

Summary: The 5 stream of the minetest module has broken dependencies and cannot be installed.
Product: [Fedora] Fedora Modules Reporter: Lukas Ruzicka <lruzicka>
Component: minetestAssignee: Aleksandra Fedorova <alpha>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: alpha, bond.masuda, dulsi, extras-orphan, gwync, igor.raits, jean-baptiste, j.frost, vascom2
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-12-21 09:34:45 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Lukas Ruzicka 2019-10-23 13:09:33 UTC
Description of problem:

The 5 stream of the minetest module has broken dependencies and cannot be installed.

Version-Release number of selected component (if applicable):

5.0.0-1.module_f31+3570+17c32fe9.x86_64

How reproducible:

Always

Steps to Reproduce:
1. dnf module install minetest:5/client

or

2. dnf module install minetest:5/server

Additional info:

Problem: conflicting requests
- nothing provides libjsoncpp.so.19()(64bit) needed by minetest-5.0.0-1.module_f31+3570+17c32fe9.x86_64

Comment 1 Igor Raits 2019-10-23 13:11:18 UTC
jsoncpp maintainer should fix this.

Comment 2 Bond Masuda 2019-11-16 23:08:39 UTC
experiencing this issue myself too. also, looks like this might be duplicate: https://bugzilla.redhat.com/show_bug.cgi?id=1770568

Comment 3 S├ębastien Willmann 2019-11-17 09:54:14 UTC
The module build looks old (march), jsoncpp was updated since then. Simply rebuilding the module should fix the issue but it looks like the stream is not supported anymore.

Comment 4 Jack Frost 2019-11-18 18:56:25 UTC
Is there anything we can do as users to install minetest on Fedora 31 other than using flatpak?

Comment 5 Vasiliy Glazov 2019-12-11 12:34:23 UTC
(In reply to Jack Frost from comment #4)
> Is there anything we can do as users to install minetest on Fedora 31 other
> than using flatpak?

You can try rebuild it with current jsoncpp.

Comment 6 Dennis Payne 2019-12-11 19:22:03 UTC
Rebuilding the source rpm does work.

Comment 7 Gwyn Ciesla 2019-12-17 14:55:57 UTC
Based on what I see in pagure, this has been demodularized. If you disable the module stream, you should be able to unstall 4.x. 5.x is available in rawhide and should IMHO be backported to f31 due to the module problem.

Comment 9 Aleksandra Fedorova 2019-12-18 14:26:11 UTC
I requested reopening of a modular branch https://pagure.io/releng/issue/9112 so that I can push modular updates to f30 and f31

Comment 10 Fedora Update System 2019-12-21 02:14:49 UTC
minetest-5-3120191217165623.f636be4b has been pushed to the Fedora 31 Modular stable repository. If problems still persist, please make note of it in this bug report.