Bug 1765009

Summary: Resources Tab under Custom Resource details page for installed operator does not list Custom Resources
Product: OpenShift Container Platform Reporter: umanga <uchapaga>
Component: Management ConsoleAssignee: Samuel Padgett <spadgett>
Status: CLOSED ERRATA QA Contact: umanga <uchapaga>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.2.0CC: amerdler, aos-bugs, jokerman, yapei
Target Milestone: ---   
Target Release: 4.3.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-01-23 11:09:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Empty Resources Tab under Storage Cluster
none
Storage Cluster Shown none

Description umanga 2019-10-24 07:14:47 UTC
Created attachment 1628717 [details]
Empty Resources Tab under Storage Cluster

Description of problem:
Resource Tab under Installed Operators > ocs-operator > StorageCluster is empty.
StorageCluster owns some other custom resources and is cleary stated in the CSV spec. But, even though these resources exist in the cluster, it is not listed under Resource tab.

There is no api request being sent to fetch these resources like it does for resources like secrets and configmaps etc.

console log:
```
kindObj: no model for kind CephCluster main-chunk-609e2d76996876b27767.min.js:1
kindObj: no model for kind NooBaa main-chunk-609e2d76996876b27767.min.js:1
No model registered for CephCluster main-chunk-609e2d76996876b27767.min.js:1
No model registered for NooBaa main-chunk-609e2d76996876b27767.min.js:1
kindObj: no model for kind CephCluster main-chunk-609e2d76996876b27767.min.js:1
kindObj: no model for kind NooBaa
```

Version-Release number of selected component (if applicable):
OCP 4.2.0
OCS 4.2.0

How reproducible:
100%

Steps to Reproduce:
1. Install ocs operator (https://github.com/openshift/ocs-operator#install)
2. Create a StorageCluster 
3. Navigate to Resources Tab for StorageCluster
4. Inspect the Requests and Console Log

Actual results:
Page is blank.

Expected results:
It should list Custom Resources and other resources as mentioned in the CSV

Additional info:

Comment 1 Alec Merdler 2019-10-29 19:27:17 UTC
Issue is caused by trying to create a <Firehose> using just `kind`, when runtime CRDs require a full `GroupVersionKind`. Changing (https://github.com/openshift/console/blob/master/frontend/packages/operator-lifecycle-manager/src/components/k8s-resource.tsx#L90) to build a `GroupVersionKind` for CRDs will fix the issue.

Comment 2 Samuel Padgett 2019-10-30 19:19:16 UTC
*** Bug 1765015 has been marked as a duplicate of this bug. ***

Comment 4 Yadan Pei 2019-11-06 07:33:27 UTC
1. Install OCS operator, when OCS operator is succesfully installed create StorageCluster following the steps in (https://github.com/openshift/ocs-operator#install)
2. Check if StorageCluster is created or not
$ oc get storagecluster -n openshift-storage
NAME                     AGE
example-storagecluster   3m43s
3. Go to Operator Hub -> Installed Operators -> OpenShift Container Storage Operator -> All Instances
Warning message is shown
kindObj: no model for kind ceph.rook.io~v1~CephNFS backend.js:6:2313
kindObj: no model for kind ocs.openshift.io~v1~OCSInitialization backend.js:6:2313
kindObj: no model for kind ocs.openshift.io~v1~StorageClusterInitialization backend.js:6:2313
No model registered for ceph.rook.io~v1~CephCluster backend.js:6:2313
No model registered for ceph.rook.io~v1~CephBlockPool backend.js:6:2313
No model registered for ceph.rook.io~v1~CephObjectStore backend.js:6:2313
No model registered for ceph.rook.io~v1~CephObjectStoreUser backend.js:6:2313
No model registered for ceph.rook.io~v1~CephNFS backend.js:6:2313
No model registered for noobaa.io~v1alpha1~NooBaa backend.js:6:2313
No model registered for noobaa.io~v1alpha1~BackingStore backend.js:6:2313
No model registered for noobaa.io~v1alpha1~BucketClass backend.js:6:2313
No model registered for ocs.openshift.io~v1~OCSInitialization backend.js:6:2313
No model registered for ocs.openshift.io~v1~StorageCluster backend.js:6:2313
No model registered for ocs.openshift.io~v1~StorageClusterInitialization
...

When click on 'Storage Cluster' resource tab, the created storagecluster can't be loaded and show on page
404: Page Not Found
The server doesn't have a resource type StorageCluster. Try refreshing the page if it was recently added.

This is checked against 4.3.0-0.nightly-2019-11-05-164935

Comment 5 Yadan Pei 2019-11-06 08:28:39 UTC
This maybe caused by a not totally completed installation of OCS operator, I will check again when I get a successfully OCS operator.

Moving back to ON_QA again

Comment 6 Yadan Pei 2019-11-07 03:42:17 UTC
Checked again on 4.3.0-0.nightly-2019-11-06-215135 with steps in comment 4, the created storagecluster/example-storagecluster is shown on Storage Cluster tab

Comment 7 Yadan Pei 2019-11-07 03:43:00 UTC
Created attachment 1633520 [details]
Storage Cluster Shown

Comment 8 Yadan Pei 2019-11-07 05:01:22 UTC
Sorry I misunderstood the bug, it says the owned resources of StorageCluster are not shown in 'Resource' tab

Can you help verify? I can't get a successful OCS operator installed on my cluster

Comment 10 Yadan Pei 2019-11-07 08:09:02 UTC
Thank you very much, umanga

Comment 12 errata-xmlrpc 2020-01-23 11:09:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062