Bug 1766231

Summary: Free Pascal Compiler 3.2.0
Product: [Fedora] Fedora Reporter: Ben Cotton <bcotton>
Component: Changes TrackingAssignee: Artur Frenszek-Iwicki <fedora>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 32CC: bcotton, joost
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-04-28 14:30:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ben Cotton 2019-10-28 15:50:35 UTC
This is a tracking bug for Change: Free Pascal Compiler 3.2.0
For more details, see: https://fedoraproject.org/wiki/Changes/Free_Pascal_Compiler_3.2.0

Update the Free Pascal Compiler used within Fedora to version 3.2.0, once it is published, and enable building (previously unsupported) AArch64 and ppc64le packages using the compiler.

Comment 1 Artur Frenszek-Iwicki 2020-01-24 10:21:35 UTC
When this issue was created, FPC 3.2.0 was loosely stated to come out somewhere before the end of 2019. That didn't happen.

Looking at FPC forums, there are currently only two bugs blocking the release:

- https://bugs.freepascal.org/view.php?id=36176
A bug in Currency (fixed-point real numbers) calculations. However, it affects only Win64.

- https://bugs.freepascal.org/view.php?id=36456
An error when trying to use the "rpm" target in FPC's Makefiles - not used by Fedora.

Since the F32 Mass Rebuild date is approaching soon and none of those bugs affect Fedora, my proposal is to update FPC within F32 to the latest SVN revision of the 3.2 branch.

Comment 2 Artur Frenszek-Iwicki 2020-01-26 13:52:21 UTC
FPC 3.2.0-beta has been built for Rawhide: https://koji.fedoraproject.org/koji/taskinfo?taskID=41037192

Comment 3 Artur Frenszek-Iwicki 2020-01-28 09:11:01 UTC
FPC 3.2.0-beta has been bootstrapped for ppc64le:
https://koji.fedoraproject.org/koji/buildinfo?buildID=1432889

There were some minor problems with the aarch64 bootstrap, so it was done separately in a later build:
https://koji.fedoraproject.org/koji/buildinfo?buildID=1432988

Comment 4 Ben Cotton 2020-02-11 18:13:53 UTC
Branching Fedora 32 Changes from rawhide. Today is the Code Complete (testable) deadline. Please make sure your bug status is set appropriately:

Complete (testable) -> MODIFIED
Complete (100% code complete) -> ON_QA (deadline is 25 February)

If you need to defer this change until Fedora 33, please set the version back to 'rawhide'.

Comment 5 Ben Cotton 2020-02-24 18:31:14 UTC
Setting to ON_QA since FESCo reports this is done: https://meetbot.fedoraproject.org/sresults/fesco.2020-02-24-15.00.log.html#l-267

Comment 6 Ben Cotton 2020-04-28 14:30:26 UTC
Fedora 32 is released!