Bug 1767265

Summary: Lyx 2.3.3 editor buffer flashes after typing a line and rest of window looks like desktop background.
Product: [Fedora] Fedora Reporter: Bruce Bigby <bbigby64>
Component: lyxAssignee: Rex Dieter <rdieter>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 31CC: itaybm2, jamatos, o.meplan, rdieter
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Fixed In Version: lyx-2.3.4-1.fc31 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-02-04 01:24:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Description Flags
Screenshot of Lyx. none

Description Bruce Bigby 2019-10-31 02:45:17 UTC
Created attachment 1630871 [details]
Screenshot of Lyx.

Description of problem:

When I open a new Lyx document, select 'File' from the menu, the menu appears further down than normal; it appears detached yet still attached.

Also, when I type some characters, the entire edit window looks like the desktop background image except the line that I'm typing.  Once I type enter, all of the lines that I typed return, and the entire editor window looks normal.

If I type a line without pressing Return/Enter, and place the cursor within the editing window but NOT on the line that I typed, the line will flash.

Version-Release number of selected component (if applicable):

Lyx 2.3.3

How reproducible:

Steps to Reproduce:
1. Just open a Lyx window, start typing, and observe the odd behavior.

Actual results:

Quirky behavior. Flashing line.  Most of the Lyx input window is blank and it looks like the desktop background.

Expected results:

It should behave as it does normally in previous builds.

Additional info:

Comment 1 Bruce Bigby 2019-10-31 02:47:13 UTC
This problem makes Lyx virtually unusable.

Comment 2 Bruce Bigby 2019-10-31 02:48:57 UTC
By the way, I even rebooted and open Lyx again to test whether the problem would go away.  It didn't.  There is a bug with the application or in a library upon which Lyx depends -- maybe a QT issue, or with the QT code that interfaces with GDK.

Comment 3 Bruce Bigby 2019-10-31 18:03:27 UTC
Also, when I click on the Style/Class menu, the drop down list doesn't appear.

Comment 4 Bruce Bigby 2019-11-01 01:46:45 UTC
The problems with Lyx appear to be related to Wayland.  When I run Lyx within an Xorg session, it works fine, although I had no problems when running Lyx under Wayland in Fedora 30, although I don't recall whether Lyx was running as an XWayland client or straight Wayland client.  In Fedora 31, Lyx appears to be a straight Wayland client.

Comment 5 Bruce Bigby 2019-11-01 02:02:04 UTC
I guess that I should qualify my last statement.  Under Wayland, Lyx appears to run as a straight Wayland client, but it has issues when it does so.  When I run Lyx under an Xorg session, it runs fine.

Comment 6 Bruce Bigby 2019-11-08 00:50:08 UTC
There is a corresponding bug on the Lyx Project bug tracking site.  See ...


There appears to be a patch to fix the problem.

Comment 7 O. Meplan 2019-11-18 19:21:21 UTC
Hello !
I have exactly the same problem. Any fix on Fedora repo?

Comment 8 Itay 2019-12-11 12:41:44 UTC
I have the same problem on Fedora 31.

Comment 9 Bruce Bigby 2019-12-13 00:09:40 UTC
Also, on a dual monitor system, sometimes Lyx drop-down menus behave in a weird way.  On my primary monitor, they appear shifted down with a gap between the menu item and the menu list.  Also, if I move the Lyx to my secondary monitor and click a drop-down menu item, the menu doesn't appear.

Comment 10 Bruce Bigby 2019-12-29 02:21:41 UTC
I also found a simple workaround using ssh.  Just login to your current account using ssh and then run lyx from the command line in the background, or foreground if you wish -- for example,

ssh -X localhost
lyx &

On my box, although lyx runs with a light theme instead of my preferred Dark Theme, the menus appear intact and when I edit documents, there's no flashing or anything odd while editing a document.

Comment 11 Bruce Bigby 2019-12-30 01:05:00 UTC
A cleaner workaround is to create a bin directory,

mkdir -p $HOME/bin
cd $HOME/bin

and create a script, called lyx, in the $HOME/bin directory whose contents looks like the following:


ssh -X localhost /usr/bin/lyx &

and then, make the script executable as in the following:

chmod 755 lyx

Then, make sure that the directory, $HOME/bin, precedes the directory /usr/bin/ in your environment's PATH variable -- for example,

echo $PATH

Now, when you run lyx from the terminal or click on the lyx icon launcher, the script above will run in X11 mode and operate normally, but with the exception that the Light theme of lyx might not match the theme of your  desktop.

The patches for fixing the issues with lyx are supposed to arrive in lyx 2.3.4, but until then, this is a fairly clean workaround.

However, once 2.3.4 is available on your system, you can either eliminate or rename the script so that the system will find and run the lyx 2.3.4 binary directly or you can keep your script in place and modify it so that it does not invoke the ssh command as in the following:


/usr/bin/lyx &

If lyx is working properly, then you can continue with the script or delete it altogether. However, if lyx is not working properly, then you can restore the script to its original state:


ssh -X localhost /usr/bin/lyx &

Note: You might have to enter your ssh password during the lyx launch process.

Comment 12 Fedora Update System 2020-01-31 01:28:54 UTC
lyx-2.3.4-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-447afa6b58

Comment 13 Fedora Update System 2020-02-04 01:24:35 UTC
lyx-2.3.4-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.