Bug 1767945

Summary: Language selection list overflow
Product: [Fedora] Fedora Reporter: Douglas <doug.hs>
Component: firefoxAssignee: Jan Horak <jhorak>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 31CC: 0xalen+redhat, anto.trande, gecko-bugs-nobody, jhorak, john.j5live, kengert, pjasicek, rhughes, rstrode, sandmann, stransky
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: firefox-70.0.1-4.fc30 firefox-70.0.1-4.fc31 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-11-17 01:13:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Screenshot of the problem none

Description Douglas 2019-11-01 17:14:51 UTC
Created attachment 1631569 [details]
Screenshot of the problem

Description of problem:
The list where you select the languages used in the HTTP Accept-Language header is overflowing and is impossible to see what item is selected if the item is located beyond the screen limits. See screenshot.

Version-Release number of selected component (if applicable):
firefox-70.0-1.fc31.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Open Firefox and go to Settings
2. In General settings, Language, press the button "Select" where it says "Choose your favorite languages to display pages".
3. On the overlay window that opens, select a language to add.

Actual results:
List overflows the screen

Expected results:
List should have a limited height and scroll properly up and down.

Additional info:
- From my tests, it appears this is only reproducible on Wayland, not on Xorg session.
- This is also reproducible on Ubuntu 19.10 (Eoan)

Comment 1 Martin Stransky 2019-11-01 17:17:42 UTC
I think Jan already has a patch for it, right?

Comment 2 Jan Horak 2019-11-14 14:37:38 UTC
Looks like dupe of bug 1768217.

Comment 3 Fedora Update System 2019-11-15 09:00:00 UTC
FEDORA-2019-16b2e506b5 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-16b2e506b5

Comment 4 Fedora Update System 2019-11-15 09:00:01 UTC
FEDORA-2019-d35fb838cd has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d35fb838cd

Comment 5 Fedora Update System 2019-11-16 00:53:52 UTC
firefox-70.0.1-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d35fb838cd

Comment 6 Fedora Update System 2019-11-16 01:17:00 UTC
firefox-70.0.1-4.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-14dc54e0d6

Comment 7 Fedora Update System 2019-11-16 01:51:43 UTC
firefox-70.0.1-4.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-16b2e506b5

Comment 8 Fedora Update System 2019-11-17 01:13:50 UTC
firefox-70.0.1-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2019-11-17 01:31:25 UTC
firefox-70.0.1-4.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.