Bug 1768536

Summary: [RHEL 8 docs] FS fails to mount if we lvextend the LV with a new PV with different sector size
Product: Red Hat Enterprise Linux 8 Reporter: Marek Suchánek <msuchane>
Component: lvm2Assignee: Marek Suchánek <msuchane>
lvm2 sub component: Changing Logical Volumes QA Contact: cluster-qe <cluster-qe>
Status: CLOSED WONTFIX Docs Contact: Marek Suchánek <msuchane>
Severity: medium    
Priority: unspecified CC: agk, heinzm, jbrassow, jcall, lmanasko, lvm-team, msnitzer, pasik, prajnoha, teigland, zkabelac
Version: 8.0   
Target Milestone: rc   
Target Release: 8.2   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Known Issue
Doc Text:
.LVM no longer allows creating volume groups with mixed block sizes LVM utilities such as `vgcreate` or `vgextend` no longer allow you to create volume groups (VGs) where the physical volumes (PVs) have different logical block sizes. LVM has adopted this change because file systems fail to mount if you extend the underlying logical volume (LV) with a PV of a different block size. To re-enable creating VGs with mixed block sizes, set the `allow_mixed_block_sizes=1` option in the `lvm.conf` file.
Story Points: ---
Clone Of: 1669751 Environment:
Last Closed: 2021-05-04 07:30:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1669751    
Bug Blocks:    

Comment 8 RHEL Program Management 2021-05-04 07:30:31 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.