Bug 1769088

Summary: Unable to scroll through font list in Wayland
Product: [Fedora] Fedora Reporter: James <james>
Component: firefoxAssignee: Jan Horak <jhorak>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 31CC: 0xalen+redhat, anto.trande, gecko-bugs-nobody, jhorak, john.j5live, kengert, pjasicek, rhughes, rstrode, sandmann, stransky
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: firefox-70.0.1-4.fc30 firefox-70.0.1-4.fc31 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-11-17 01:13:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Screenshot of the issue none

Description James 2019-11-05 21:49:32 UTC
Created attachment 1633093 [details]
Screenshot of the issue

Description of problem:
The font selection drop-down in Firefox preferences expands off-screen if the font list is too long, rather than stay smaller than the screen and provide a facility to scroll through it. 

This only happens in Wayland. I get a scrollbar in X.

Screenshot attached.

Version-Release number of selected component (if applicable):
firefox-70.0-1.fc31.x86_64
gnome-shell-3.34.1-2.fc31.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Log into a Wayland session.
2. Start Firefox, go to the preferences.
3. Select the font drop-down.

Comment 1 Martin Stransky 2019-11-06 07:13:42 UTC
Jan is solving that.

Comment 2 Jan Horak 2019-11-14 14:38:50 UTC
Looks like dupe of bug 1768217.

Comment 3 Fedora Update System 2019-11-15 08:59:59 UTC
FEDORA-2019-d35fb838cd has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d35fb838cd

Comment 4 Fedora Update System 2019-11-15 08:59:59 UTC
FEDORA-2019-14dc54e0d6 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-14dc54e0d6

Comment 5 Fedora Update System 2019-11-16 00:53:52 UTC
firefox-70.0.1-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d35fb838cd

Comment 6 Fedora Update System 2019-11-16 01:16:59 UTC
firefox-70.0.1-4.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-14dc54e0d6

Comment 7 Fedora Update System 2019-11-16 01:51:42 UTC
firefox-70.0.1-4.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-16b2e506b5

Comment 8 Fedora Update System 2019-11-17 01:13:48 UTC
firefox-70.0.1-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2019-11-17 01:31:24 UTC
firefox-70.0.1-4.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.