Bug 176978

Summary: Only video card in the system gets detected as a second head.
Product: [Fedora] Fedora Reporter: Hans de Goede <hdegoede>
Component: rhpxlAssignee: Chris Lumens <clumens>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: david.r.bentley, fedora, notting
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: 0.15-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-15 16:45:53 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
old kudzu -p output from 1.2.25-1
none
new kudzu -p output from 1.2.26-1
none
Log starting X with xorg.conf created with radeon driver none

Description Hans de Goede 2006-01-04 17:13:05 EST
I was having some other X troubles with the latest rawhide so I tried to
recreate a clean Xorg.conf with: system-config-display --reconfig

Run as root from a console, both in runlevel 3 and 5 this gives the following
device section in the new xorg.conf:

Section "Device"
        Identifier  "Videocard0"
        Driver      "vesa"
        VendorName  "Videocard vendor"
        BoardName   "ATI Technologies Inc RV280 [Radeon 9200 PRO] (Secondary)"
EndSection

Notice how it thinks this is a secondary card and decides to use vesa for some
strange reason.
Comment 1 David Bentley 2006-01-19 14:10:15 EST
On a newly instaled FC5T2 my video card is detected in a similar manner ie
ATI Technologies Inc RV350 [Radeon 9800 PRO] (Secondary)" and also ends up with 
the vesa driver.

In FC5T1 you had to edit the xorg.conf and substitute "vesa" with "radeon" which
I did again for FC5T2 but now as of 19/1/06 system-config-display works and
allows you to change the config (I changed it from radeon to ati which also
works OK)

But for some reason the sytem still insists on calling the first head (secondary)
Comment 2 Bill Nottingham 2006-02-06 11:43:24 EST
Actually, moving back to s-c-display.
Comment 3 Bill Nottingham 2006-02-06 15:43:10 EST
*** Bug 180073 has been marked as a duplicate of this bug. ***
Comment 4 Mike A. Harris 2006-02-06 17:57:58 EST
system-config-display should never assign class 0380 devices to entries in
xorg.conf

Only class 0300 should get entries in xorg.conf.
Comment 5 Bill Nottingham 2006-02-10 11:34:57 EST
*** Bug 180016 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2006-02-13 12:01:44 EST
kudzu-1.2.26-1 may solve this.
Comment 7 Andy Burns 2006-02-13 14:09:46 EST
I'll check with rawhide 2006-02-14, unless there's a source for
kudzu-1.2.26-1.x86_64.rpm on people.redhat.com I can try sooner?
Comment 8 Bill Nottingham 2006-02-13 14:10:55 EST
http://people.redhat.com/notting/kudzu/
Comment 9 Andy Burns 2006-02-13 15:47:00 EST
Created attachment 124575 [details]
old kudzu -p output from 1.2.25-1
Comment 10 Andy Burns 2006-02-13 15:49:53 EST
Created attachment 124576 [details]
new kudzu -p output from 1.2.26-1

The difference is that the secondary part of the card is detected much earlier
in the process, and is assigned class "OTHER" instead of class "VIDEO"

However this seems to break system-config-display, unless anything else broke
it in the last few days?

# system-config-display
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 294, in ?
    vc = rhpxl.videocard.VideoCardInfo()
  File "/usr/lib/python2.4/site-packages/rhpxl/videocard.py", line 286, in
__init__
    if drivers.has_key(card.xdriver):
AttributeError: pciDevice instance has no attribute 'xdriver'
Comment 11 Bill Nottingham 2006-02-13 16:26:28 EST
Oops. Try 1.2.27-1 in the same place. :)
Comment 12 Andy Burns 2006-02-13 16:48:27 EST
OK

# system-config-display --verbose --reconfig --noui
Trying with card: ATI Technologies Inc RV370 [ATI Sapphire X550 Silent]
Backing up /etc/X11/xorg.conf as /etc/X11/xorg.conf.backup
Writing configuration to /etc/X11/xorg.conf
Removing old /etc/X11/X
Creating /etc/X11/X symlink
Kicking gdm

Does now create an xorg.cong with radeon driver instead of vesa, got to exit
firefox to see if it works, back in a tick ....
Comment 13 Andy Burns 2006-02-13 17:00:07 EST
Created attachment 124579 [details]
Log starting X with xorg.conf created with radeon driver

Nope, X refused to start, so kudzu/system-configure-display seem to now be
doing the right thing, but the xorg-x11-drv-ati still requires the extra ChipId
that I logged in my original BZ that got dup'ed to this one, keep it here, or
re-open that?
Comment 14 Bill Nottingham 2006-02-13 17:15:49 EST
Probably repoen that.
Comment 15 Paul Nasrat 2006-02-14 16:46:45 EST
Note this change breaks iMac video card detection, which is a class 380 device:

00:10:.0 0380: 1002:5052
(Display controller: ATI Technologies Inc Rage 128 PR/PRO AGP 4x TMDS).
Comment 16 Bill Nottingham 2006-02-15 16:45:53 EST
kudzu fix reverted in 1.2.30-1. fix added in rhpxl-0.15-1.