Bug 1770568

Summary: Conflicting requests libjsoncpp.so.19
Product: [Fedora] Fedora Reporter: Artem <ego.cordatus>
Component: minetestAssignee: Aleksandra Fedorova <alpha>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 31CC: alpha, bugzilla, cbm, igor.raits, jean-baptiste, j.frost, oliver, rosser.bjr, samuel-rhbugs
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-12-21 09:36:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Artem 2019-11-10 15:35:08 UTC
Description of problem:
  Minetest won't install.

Version-Release number of selected component (if applicable):
  minetest-5.0.0-1.module_f31+3570+17c32fe9

How reproducible:
  sudo dnf install minetest

Actual results:
  conflicting requests
  - nothing provides libjsoncpp.so.19()(64bit) needed by minetest-5.0.0-1.module_f31+3570+17c32fe9.x86_64
Expected results:


Additional info:
  Fedora 31 with all updates installed.

Comment 1 Colin Macdonald 2019-11-11 07:49:25 UTC
I suggest we bump to 5.1.0 in f31 (already in Rawhide).  Have tested and works for me!

Comment 2 Colin Macdonald 2019-11-17 23:46:17 UTC
My kids play this all the time so I'm happy to help with packaging.  Can you add me and I'll do the bump in f31?  Fedora username: cbm.

Comment 3 Artem 2019-11-22 02:39:32 UTC
I can help with building and pushing update in Bodhi if you wish.
FAS: atim

It compiles and run without any issue. Already build and tested locally. Just build 5.1 Rawhide version for F31.

Comment 4 Artem 2019-12-11 12:51:43 UTC
Workaround is:

  sudo dnf module disable minetest

After that you can install minetest without this trouble. Thanks for tip @ignatenkobrain

Comment 5 Fedora Update System 2019-12-18 18:14:04 UTC
FEDORA-MODULAR-2019-44e78ce21d has been submitted as an update to Fedora 31 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-44e78ce21d

Comment 6 Fedora Update System 2019-12-19 15:45:11 UTC
minetest-5-3120191217165623.f636be4b has been pushed to the Fedora 31 Modular testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-44e78ce21d

Comment 7 Fedora Update System 2019-12-21 02:14:53 UTC
minetest-5-3120191217165623.f636be4b has been pushed to the Fedora 31 Modular stable repository. If problems still persist, please make note of it in this bug report.