Bug 1770816

Summary: polymake-jupyter fails to install in Fedora rawhide
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: polymakeAssignee: Jerry James <loganjerry>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: jamesturner246, loganjerry, richmattes, william.garber
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: polymake-3.6-1.fc31 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-12-16 01:19:08 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1750909    

Description Miro Hrončok 2019-11-11 11:58:19 UTC
polymake-jupyter-0.16-9.fc32.noarch fails to install in Fedora rawhide:

  package polymake-jupyter-0.16-9.fc32.noarch requires python3-JuPyMake = 0.8-9.fc32, but none of the providers can be installed
  package python3-JuPyMake-0.8-9.fc32.x86_64 requires libpolymake.so.3.5()(64bit), but none of the providers can be installed
  nothing provides perl-interpreter = 4:5.30.0 needed by polymake-singular-3.5-5.fc32.x86_64
    (we have perl-interpreter-4:5.30.1-447.fc32.x86_64)

Comment 1 James Paul Turner 2019-11-20 19:23:00 UTC
Hi Miro.

This should all be fixed in

https://bodhi.fedoraproject.org/updates/FEDORA-2019-bf01e6f295

pending one more karma vote.

Comment 2 Fedora Update System 2019-11-29 18:11:35 UTC
FEDORA-2019-b9d4340b95 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b9d4340b95

Comment 3 Fedora Update System 2019-12-02 18:32:45 UTC
FEDORA-2019-b9d4340b95 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b9d4340b95

Comment 4 Fedora Update System 2019-12-03 00:53:38 UTC
Singular-4.1.1p3-10.fc31, cocoalib-0.99650-1.fc31, giac-1.5.0.63-4.fc31, normaliz-3.8.3-1.fc31, polymake-3.6-1.fc31, python-jupymake-0.9-1.20190509.031cc3a.fc31, python-jupyter-polymake-0.16-11.20180129.7049940.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b9d4340b95

Comment 5 Fedora Update System 2019-12-07 17:10:49 UTC
FEDORA-2019-b9d4340b95 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b9d4340b95

Comment 6 Fedora Update System 2019-12-08 01:46:39 UTC
Singular-4.1.1p3-10.fc31, cocoalib-0.99650-1.fc31, giac-1.5.0.75-2.fc31, normaliz-3.8.3-1.fc31, polymake-3.6-1.fc31, python-jupymake-0.9-1.20190509.031cc3a.fc31, python-jupyter-polymake-0.16-11.20180129.7049940.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b9d4340b95

Comment 7 Fedora Update System 2019-12-16 01:19:08 UTC
Singular-4.1.1p3-10.fc31, cocoalib-0.99650-1.fc31, giac-1.5.0.75-2.fc31, normaliz-3.8.3-1.fc31, polymake-3.6-1.fc31, python-jupymake-0.9-1.20190509.031cc3a.fc31, python-jupyter-polymake-0.16-11.20180129.7049940.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 william.garber 2020-03-18 21:33:12 UTC
looks like I am having the same problem.

Comment 9 Jerry James 2020-03-18 21:49:43 UTC
This is an old, closed bug.  If you are having a problem, please open a new bug and provide details.  I just verified that I can install python3-jupymake in both F31 and Rawhide, so I'll need to know more about your problem before I can fix it.