Bug 1773380

Summary: upm fails to build with Python 3.8 on Fedora 32+
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: upmAssignee: Peter Robinson <pbrobinson>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: pbrobinson
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-11-18 10:28:38 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1721671    
Bug Blocks: 1750908, 1750909, 1686977    

Description Miro Hrončok 2019-11-17 23:25:55 UTC
upm fails to build with Python 3.8.0b4 in Fedora 32.

See the build failures at https://koji.fedoraproject.org/koji/search?match=glob&type=package&terms=upm

DEBUG util.py:593:  Error: 
DEBUG util.py:593:   Problem 1: conflicting requests
DEBUG util.py:593:    - nothing provides nodejs(v8-abi6) >= 6.8 needed by nodejs-mraa-2.0.0-4.fc31.x86_64
DEBUG util.py:593:    - nothing provides nodejs(abi10) >= 10.16 needed by nodejs-mraa-2.0.0-4.fc31.x86_64
DEBUG util.py:593:   Problem 2: conflicting requests
DEBUG util.py:593:    - nothing provides python(abi) = 3.7 needed by python3-mraa-2.0.0-4.fc31.x86_64

It is not important whether the problem is relevant to Python 3.8, or whether the problem is caused by this package or another, this issue is blocking the Python 3.8 rebuild of this package.

If this package won't build with 3.8, it won't be installable, along with all its dependent packages, in Fedora 32 and further.

Furthermore, as it fails to install, its dependent packages will fail to install and/or build as well.

Please rebuild the package in Fedora 32 (rawhide).

Let us know here if you have any questions. Thank You!

Comment 1 Peter Robinson 2019-11-18 10:28:38 UTC

*** This bug has been marked as a duplicate of bug 1736936 ***