Bug 1774813

Summary: Private GCP cluster install fails due to bootstrap node in master instance group
Product: OpenShift Container Platform Reporter: Patrick Dillon <padillon>
Component: InstallerAssignee: Patrick Dillon <padillon>
Installer sub component: openshift-installer QA Contact: Gaoyun Pei <gpei>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: unspecified CC: wsun
Version: 4.3.0Keywords: Regression, TestBlocker
Target Milestone: ---   
Target Release: 4.3.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-01-23 11:13:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 2 Patrick Dillon 2019-11-22 10:47:57 UTC
https://github.com/openshift/installer/pull/2697

Comment 4 Gaoyun Pei 2019-11-25 06:57:11 UTC
Verify this bug with 4.3.0-0.nightly-2019-11-24-183610

Bootstrap node was created in a standalone bootstrap instance group during installation.

Ingress is working as expected.

# oc get service -n openshift-ingress
NAME                      TYPE           CLUSTER-IP      EXTERNAL-IP   PORT(S)                      AGE
router-default            LoadBalancer   172.30.55.234   10.0.32.4     80:30765/TCP,443:31645/TCP   98m
router-internal-default   ClusterIP      172.30.54.145   <none>        80/TCP,443/TCP,1936/TCP      98m

Comment 6 errata-xmlrpc 2020-01-23 11:13:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062