Bug 1776394

Summary: inconsistent cloud-credential operator monitoring config
Product: OpenShift Container Platform Reporter: Luis Sanchez <sanchezl>
Component: Cloud Credential OperatorAssignee: Joel Diaz <jdiaz>
Status: CLOSED ERRATA QA Contact: Xiaoli Tian <xtian>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 4.3.0CC: jdiaz
Target Milestone: ---   
Target Release: 4.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-04 11:16:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Luis Sanchez 2019-11-25 15:26:56 UTC
Description of problem:

The cloud-credential-operator ServiceMonitor specifies 
`cco.openshift-cloud-credential-operator.svc` as the serverName 
for the metrics endpoint, but there is no `cco` service in the 
`openshift-cloud-credential-operator` namespace. 


Additional info:

The naming convention seems to be to name the service and the port `metrics`.

Comment 2 Oleg Nesterov 2019-12-16 09:42:17 UTC
Verified on 4.4.0-0.nightly-2019-12-14-103510

Comment 5 errata-xmlrpc 2020-05-04 11:16:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581