Bug 1776424 (CVE-2019-16217)

Summary: CVE-2019-16217 wordpress: XSS in media uploads because wp_ajax_upload_attachment is mishandled
Product: [Other] Security Response Reporter: Guilherme de Almeida Suckevicz <gsuckevi>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: fedora, kevin
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-12-26 19:01:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1776425, 1776426    
Bug Blocks:    

Description Guilherme de Almeida Suckevicz 2019-11-25 16:40:45 UTC
WordPress before 5.2.3 allows XSS in media uploads because wp_ajax_upload_attachment is mishandled.

Reference:
https://core.trac.wordpress.org/changeset/45936

Comment 1 Guilherme de Almeida Suckevicz 2019-11-25 16:41:26 UTC
Created wordpress tracking bugs for this issue:

Affects: epel-6 [bug 1776425]
Affects: epel-7 [bug 1776426]

Comment 2 Kevin Fenzi 2020-12-26 19:01:53 UTC
Fixed in 5.2.4