Bug 1776815

Summary: [Intel OSP16] DPDK Telemetry Plugin
Product: Red Hat OpenStack Reporter: Emma Collins <emma.collins>
Component: collectdAssignee: Ryan McCabe <rmccabe>
Status: CLOSED WONTFIX QA Contact: Leonid Natapov <lnatapov>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 16.0 (Train)CC: brault, dcadzow, fbaudin, jbadiapa, mmagr, mrunge, rmccabe
Target Milestone: betaKeywords: FutureFeature, OtherQA, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-09-18 09:25:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1817108, 1825186    
Bug Blocks:    

Description Emma Collins 2019-11-26 12:37:19 UTC
1. Feature Overview:
a) Name of feature: DPDK Telemetry 
b) Feature Description: 
This patch introduces a new plugin for collectd, which consumes DPDK metrics
via the dpdk_telemetry library. The collectd plugin here provides an
easy way to use the DPDK telemetry API to query ethernet device metrics.
The collectd reporting ethernet device metrics should be supported in OSP.

Plugin is in the process of being upstreamed

2. Feature Details:
a) Architectures:
b) Bugzilla Dependencies:
c) Drivers or hardware dependencies: n/a
d) Upstream acceptance information: Spec and implementation in progress.

e) External links:

f) Severity (H,M,L): M
g) Feature Needed by:

3. Business Justification:
a) Why is this feature needed?  This plugin replaces the DPDK stats plugin already created by intel.  Due to fact that it reads metrics differently than the OVS plugin, both plugins can now be run concurrently.
b) What hardware does this enable?
c) Is this hardware on-board in a system (eg, LOM) or an add-on card? No
d) Business impact? n.a
e) Other business drivers:

4. Primary contact at Red Hat, email, phone (chat):

5. Primary contact at Partner, email, phone (chat):
Emma Collins - Product contact: emma.collins@intel.com

Reshma Pattan - Plugin owner - Reshma.Pattan@intel.com


Can you reference OPNFV Barometer User Guide:
https://wiki.opnfv.org/display/fastpath/DPDK+Telemetry+Plugin

Comment 1 Matthias Runge 2019-11-26 14:35:32 UTC
This is https://github.com/collectd/collectd/pull/3273

Comment 4 Matthias Runge 2020-02-24 14:06:22 UTC
https://github.com/collectd/collectd/pull/3273 was merged into collectd master today.

Comment 8 Matthias Runge 2020-04-01 12:43:06 UTC
currently blocked by https://review.opendev.org/#/c/715923/4

the change in collectd has been merged, collectd-5.11 is released.

Comment 14 Alex McLeod 2020-06-16 12:28:47 UTC
If this bug requires doc text for errata release, please set the 'Doc Type' and provide draft text according to the template in the 'Doc Text' field. The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to '-'.

Comment 21 Bertrand 2020-09-18 09:25:06 UTC
This was discussed with INTEL.