Bug 1777291

Summary: Missing DESCRIPTION for oc explain kubeapiserver.spec
Product: OpenShift Container Platform Reporter: Xingxing Xia <xxia>
Component: kube-apiserverAssignee: Michal Fojtik <mfojtik>
Status: CLOSED ERRATA QA Contact: Xingxing Xia <xxia>
Severity: medium Docs Contact:
Priority: medium    
Version: 4.3.0CC: aos-bugs, geliu, maszulik, mfojtik, yinzhou
Target Milestone: ---   
Target Release: 4.3.0   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1777205 Environment:
Last Closed: 2020-01-23 11:14:35 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Xingxing Xia 2019-11-27 10:45:45 UTC
+++ This bug was initially created as a clone of Bug #1777205 +++

Same issue for kubeapiserver.spec, DESCRIPTION is empty:
oc explain kubeapiserver.spec
KIND:     KubeAPIServer
VERSION:  operator.openshift.io/v1

RESOURCE: spec <Object>

DESCRIPTION:
     <empty>

FIELDS:
   failedRevisionLimit  <integer>
     failedRevisionLimit is the number of failed static pod installer revisions
...

oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.3.0-0.nightly-2019-11-27-011055   True        False         7h53m   Cluster version is 4.3.0-0.nightly-2019-11-27-011055

Comment 2 Xingxing Xia 2019-11-28 06:26:44 UTC
Tested in env of latest payload 4.3.0-0.nightly-2019-11-28-004553, the issue still exists. Checked above PR openshift/api/pull/530/files , the zz_generated.swagger_doc_generated.go's change is not bumped into origin repo yet: https://github.com/openshift/origin/blob/release-4.3/vendor/github.com/openshift/api/operator/v1/zz_generated.swagger_doc_generated.go .

Comment 4 Xingxing Xia 2019-12-03 10:37:51 UTC
Verified in 4.3.0-0.nightly-2019-12-03-032607 with above step. Thanks

Comment 6 errata-xmlrpc 2020-01-23 11:14:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062