Bug 1777632

Summary: Retire libsearpc in Fedora 32+
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: libsearpcAssignee: Julien Enselme <jujens>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: comzeradd, cstratak, igor.raits, jujens, lbalhar, mhroncok, ngompa13, pviktori, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-01-05 20:49:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1625773, 1698500, 1708725, 1739010    

Description Miro Hrončok 2019-11-28 01:04:00 UTC
In line with the Retire Python 2 Fedora change [0], all (sub)packages of libsearpc were marked for removal.

There was no FESCo exception for this package.

Please retire your package in Rawhide (Fedora 32).

Please don't remove packages from Fedora 31/30/29, removing packages from a released Fedora branch is forbidden and out of scope of this request.

If there is no objection in a week, we will retire the package for you.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

This text is automated. We are sorry if you already communicated with us about this in another place.

[0] https://fedoraproject.org/wiki/Changes/RetirePython2

Comment 1 Miro Hrončok 2019-11-28 01:16:26 UTC
*** Bug 1738017 has been marked as a duplicate of this bug. ***

Comment 2 Miro Hrončok 2020-01-01 21:39:49 UTC
JFYI I am planning on retiring this package on Monday, 2020-01-06, if not already done by then. Request a FESCo exception by then (or report back the package is no longer depending on Python 2) if you wish to stop the procedure. Thanks

Comment 3 Julien Enselme 2020-01-05 18:25:45 UTC
I finally managed to build the package on Python 3. It seems to be working. Sorry for the delay. See: https://koji.fedoraproject.org/koji/taskinfo?taskID=40146424 and https://bodhi.fedoraproject.org/updates/FEDORA-2020-b861125619

Comment 4 Miro Hrončok 2020-01-05 20:49:28 UTC
Thanks.