Bug 1777650

Summary: Retire whipper in Fedora 32+
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: whipperAssignee: Matthew Ruszczyk <mruszczyk17>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: cstratak, igor.raits, lbalhar, mhroncok, mruszczyk17, ngompa13, pviktori, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: whipper-0.9.0-0.1.fc32 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-12-03 09:29:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1750909, 1625773, 1690439, 1698500, 1708725    

Description Miro Hrončok 2019-11-28 01:04:35 UTC
In line with the Retire Python 2 Fedora change [0], all (sub)packages of whipper were marked for removal.

There was no FESCo exception for this package.

Please retire your package in Rawhide (Fedora 32).

Please don't remove packages from Fedora 31/30/29, removing packages from a released Fedora branch is forbidden and out of scope of this request.

If there is no objection in a week, we will retire the package for you.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

This text is automated. We are sorry if you already communicated with us about this in another place.

[0] https://fedoraproject.org/wiki/Changes/RetirePython2

Comment 1 Miro Hrončok 2019-11-28 01:24:24 UTC
*** Bug 1739019 has been marked as a duplicate of this bug. ***

Comment 2 Matthew Ruszczyk 2019-12-02 23:52:13 UTC
I just submitted a prerelease package to Rawhide with Py3 support. The upstream team hopes to tag this commit as a final release later this week but I wanted to get this into Rawhide to prevent retiring this package if at all possible. If this is inappropriate please let me know. Once they tag a final Py3 build I will build a release version in Rawhide as well.

Comment 3 Zbigniew Jędrzejewski-Szmek 2019-12-03 09:29:14 UTC
This bug can be closed, whipper now only depends on python3.8.