This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 177799

Summary: hplip fails to work with HP 2550Ln (colour laserjet)
Product: [Fedora] Fedora Reporter: David Anderson <david>
Component: hplipAssignee: Tim Waugh <twaugh>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 5CC: dan
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: F-7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-10-19 10:18:14 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235704    

Description David Anderson 2006-01-14 06:38:55 EST
Description of problem: 
 
I have just installed the new hplip update for FC4 (fully updated). I have an 
HP 2550 Ln (colour laserjet) that works fine with the usb CUPS backend (and 
the HAL one) - both with the proper HP PPD or without. 
 
I installed hplip, because I was interested in having a way to find out the 
supplies status without having to print two test pages manually. 
 
After installing hplip, I restarted cups. Later on, I rebooted just to be 
sure. The hplip services start fine. 
 
I configured a printer using the hp backend (this was detected and suggested 
by s-c-p). However, printing through this backend doesn't 
work; /var/log/messages has complaints from the kernel about USB. (Sorry I 
can't paste the errors - I'm not at that computer now). 
 
hp-toolbox says that the status of the printer is offline or switched off, 
which it isn't. (I can print via the usb backend). In the status dump it 
correctly tells me the parts numbers of the installed supplies. 
 
How reproducible: Every time
Comment 1 Tim Waugh 2006-01-17 06:17:30 EST
Please supply the output of:

1. rpm -q hplip kernel
2. hp-probe
3. hp-info

I'd also like to see:

4. the /var/log/messages complaints
Comment 2 David Anderson 2006-01-19 05:51:04 EST
Here are my installed packages: 
 
[david@shed ~]$ rpm -q kernel hplip cups system-config-printer 
kernel-2.6.14-1.1637_FC4 
kernel-2.6.14-1.1644_FC4 
kernel-2.6.14-1.1653_FC4 
kernel-2.6.14-1.1656_FC4 
hplip-0.9.7-4.2 
cups-1.1.23-15.3 
system-config-printer-0.6.131.3-1 
 
[david@shed ~]$ uname -r -m 
2.6.14-1.1653_FC4 i686 
 
 
Here's what I did, with the output: 
 
0. /etc/init.d/hplip start && /etc/init.d/cups restart 
(Success) 
Jan 18 22:09:19 shed hpiod: 0.9.7 accepting connections at 50000... 
Jan 18 22:09:24 shed kernel: ppdev: user-space parallel port driver 
 
1. Printed a job using the already-set-up USB backend (just to be sure that 
everything is working - plugged in, switched on, etc.). It worked. 
 
2. Ran system-config-printer to set up a new printer. /var/log/messages has: 
 
Jan 18 22:09:37 shed hpiod: unable to read Dot4ReverseReply header: Success 
io/hpiod/dot4.cpp 245 
Jan 18 22:09:37 shed hpiod: invalid DOT4InitReply: cmd=0, result=20 , 
revision=0 io/hpiod/dot4.cpp 336 
Jan 18 22:09:37 shed kernel: drivers/usb/class/usblp.c: usblp0: nonzero 
read/write bulk status received: -2 
Jan 18 22:09:38 shed kernel: drivers/usb/class/usblp.c: usblp0: error -2 
reading from printer 
Jan 18 22:09:40 shed hpiod: unable to read Dot4ReverseReply header: 
Input/output error io/hpiod/dot4.cpp 245 
Jan 18 22:09:40 shed hpiod: invalid DOT4InitReply retrying... io/hpiod/dot4.cpp 
331 
Jan 18 22:09:41 shed su(pam_unix)[3452]: session opened for user root by 
(uid=500) 
Jan 18 22:09:43 shed hpiod: unable to read Dot4ReverseReply header: 
Input/output error io/hpiod/dot4.cpp 245 
Jan 18 22:09:43 shed hpiod: invalid DOT4InitReply: cmd=0, result=20 , 
revision=0 io/hpiod/dot4.cpp 336 
Jan 18 22:09:43 shed kernel: drivers/usb/class/usblp.c: usblp0: nonzero 
read/write bulk status received: -2 
 
Ask it to print a test page - nothing happens. /var/log/messages now also has: 
 
Jan 18 22:10:33 shed hpiod: unable to read Dot4ReverseReply header: Success 
io/hpiod/dot4.cpp 245 
Jan 18 22:10:33 shed hpiod: invalid DOT4InitReply: cmd=0, result=20 , 
revision=30 io/hpiod/dot4.cpp 336 
Jan 18 22:10:33 shed kernel: drivers/usb/class/usblp.c: usblp0: nonzero 
read/write bulk status received: -2 
Jan 18 22:10:34 shed lp0: INFO: open print channel failed; will retry in 30 
seconds... 
Jan 18 22:11:04 shed kernel: drivers/usb/class/usblp.c: usblp0: error -2 
reading from printer 
Jan 18 22:11:06 shed hpiod: unable to read Dot4ReverseReply header: 
Input/output error io/hpiod/dot4.cpp 245 
Jan 18 22:11:06 shed hpiod: invalid DOT4InitReply retrying... io/hpiod/dot4.cpp 
331 
Jan 18 22:11:09 shed hpiod: unable to read Dot4ReverseReply header: 
Input/output error io/hpiod/dot4.cpp 245 
Jan 18 22:11:09 shed hpiod: invalid DOT4InitReply: cmd=0, result=20 , 
revision=30 io/hpiod/dot4.cpp 336 
Jan 18 22:11:09 shed kernel: drivers/usb/class/usblp.c: usblp0: nonzero 
read/write bulk status received: -2 
Jan 18 22:11:10 shed lp0: INFO: open print channel failed; will retry in 30 
seconds... 
 
/var/log/cups/error_log has: 
 
I [18/Jan/2006:22:10:19 +0000] Full reload complete. 
I [18/Jan/2006:22:10:30 +0000] Adding start banner page "none" to job 1008. 
I [18/Jan/2006:22:10:30 +0000] Adding end banner page "none" to job 1008. 
I [18/Jan/2006:22:10:30 +0000] Job 1008 queued on 'printer' by 'root'. 
I [18/Jan/2006:22:10:30 +0000] Started filter /usr/lib/cups/filter/pstops (PID 
3590) for job 1008. 
I [18/Jan/2006:22:10:30 +0000] Started filter /usr/lib/cups/filter/foomatic-rip 
(PID 3591) for job 1008. 
I [18/Jan/2006:22:10:30 +0000] Started backend /usr/lib/cups/backend/hp (PID 
3592) for job 1008. 
 
3. Here is the output of hp-probe: 
 
[root@shed ~]# hp-probe 
 
 HP Linux Imaging and Printing System (ver. 0.9.7) 
 Device Detection (Probe) Utility ver. 1.3 
 
 Copyright (c) 2003-5 Hewlett-Packard Development Company, LP 
 This software comes with ABSOLUTELY NO WARRANTY. 
 This is free software, and you are welcome to distribute it 
 under certain conditions. See COPYING file for more details. 
 
   Device URI                                                 Model                                                 
   ---------------------------------------------------------  
--------------------------------                      
   hp:/usb/hp_color_LaserJet_2550_series?device=/dev/usb/lp0  HP 
hp_color_LaserJet_2550_series                      
 
4. Here is the output of hp-info: 
 
[root@shed ~]# hp-info 
 
 HP Linux Imaging and Printing System (ver. 0.9.7) 
 Device Information Utility ver. 3.2 
 
 Copyright (c) 2003-5 Hewlett-Packard Development Company, LP 
 This software comes with ABSOLUTELY NO WARRANTY. 
 This is free software, and you are welcome to distribute it 
 under certain conditions. See COPYING file for more details. 
 
 Using device: hp:/usb/hp_color_LaserJet_2550_series?device=/dev/usb/lp0 
 
 Device Parameters: 
   Parameter                     Value(s) 
   ----------------------------  
---------------------------------------------------------- 
   3bit-status-code              24 
   3bit-status-name              NoFault 
   back-end                      hp 
   cups-printers 
   cups-uri                      
hp:/usb/hp_color_LaserJet_2550_series?device=/dev/usb/lp0 
   dev-file 
   device-state                  0 
   device-uri                    
hp:/usb/hp_color_LaserJet_2550_series?device=/dev/usb/lp0 
   deviceid                      
MFG:Hewlett-Packard;CMD:PJL,PML,BIDI-ECP,MLC,PCL,POSTSCRIP 
                                T,PCLXL;MDL:hp color LaserJet 2550 
                                series;CLS:PRINTER;DES:Hewlett-Packard color 
LaserJet 2550 
                                
series;MEM:MEM=57MB;1284.4DL:4d,4e,1;COMMENT:RES=600x2; 
   error-state                   0 
   host 
   is-hp                         True 
   panel                         0 
   panel-line1 
   panel-line2 
   port                          1 
   serial 
   status-code                   5002 
   status-desc                   Device is powered down or unplugged. 
 
Model Parameters: 
   Parameter                     Value(s) 
   ----------------------------  
---------------------------------------------------------- 
   align-type                    0 
   clean-type                    0 
   color-cal-type                0 
   copy-type                     0 
   embedded-server-type          1 
   fax-type                      0 
   icon                          hp_color_LaserJet_2550.png 
   io-control                    0 
   io-mfp-mode                   4 
   io-mode                       4 
   io-scan-port                  0 
   io-support                    6 
   linefeed-cal-type             0 
   model                         hp_color_LaserJet_2550_series 
   model-ui                      HP Color LaserJet 2550 series 
   panel-check-type              1 
   pcard-type                    0 
   pq-diag-type                  0 
   r0-agent1-kind                4 
   r0-agent1-sku                 60 (Q3960A) 
   r0-agent1-type                1 
   r0-agent2-kind                4 
   r0-agent2-sku                 61/71 (Q3961/71A) 
   r0-agent2-type                4 
   r0-agent3-kind                4 
   r0-agent3-sku                 62/72 (Q3962/72A) 
   r0-agent3-type                6 
   r0-agent4-kind                4 
   r0-agent4-sku                 63/73 (Q3963/73A) 
   r0-agent4-type                5 
   r0-agent5-kind                7 
   r0-agent5-sku                 64 (Q3964A) 
   r0-agent5-type                62 
   scan-type                     0 
   status-type                   3 
   support-type                  2 
   tech-class                    Undefined 
   tech-type                     4 
 
Status History: 
   Date/Time                     Status Description (code) 
   ----------------------------  
---------------------------------------------------------- 
   18/01/06 22:14:47             Device is busy. (5031) 
   18/01/06 22:14:11             Device is busy. (5031) 
   18/01/06 22:13:35             Device is busy. (5031) 
   18/01/06 22:12:59             Device is busy. (5031) 
   18/01/06 22:12:23             Device is busy. (5031) 
   18/01/06 22:11:47             Device is busy. (5031) 
   18/01/06 22:11:11             Device is busy. (5031) 
   18/01/06 22:10:35             Device is busy. (5031) 
   18/01/06 22:10:31             The printer has started a print job. (500) 
 
 
((END)) 
 
The "device is powered down or unplugged" status is bogus - it isn't. (Because 
I can happily print to it via the usb backend - and presumably if it was 
powered down, it wouldn't be able to read all that supplies information with 
the product numbers of the toners). The printer has never shown any symptons of 
malfunction, and continues to operate flawlessly under the usb backend. 
 
Comment 3 David Anderson 2006-04-22 09:07:29 EDT
Same issue with FC5, hplip-0.9.8-6.
Comment 4 Tim Waugh 2006-05-12 12:22:11 EDT
Can you please try 0.9.11-1.1 from updates-testing?
Comment 5 David Anderson 2006-05-18 05:58:19 EDT
Yay! It worketh! Thank you!

At least, after 20 seconds testing, it seems to work. It shows me the ink 
supplies, which is all I wanted the thing for. (Otherwise I have to print a 
test page - which is 2 pages of colour, which is kind of silly if you're 
concerned about whether you're running out of ink).
Comment 6 David Anderson 2006-05-18 06:16:57 EDT
I've played for about 20 minutes - all seems fine.

(Except that it displays "Good/OK" and "1%" for the yellow toner level, which 
doesn't tally - but the printer's always had a problem with this; it's not 
software).
Comment 7 David Anderson 2006-05-18 13:40:47 EDT
Argh! It worketh not!

Of course, the only thing I didn't actually try was _printing_... I just 
assumed that'd work. Which it doesn't.

I get this in /var/log/messages:

May 18 18:38:37 shed hpiod: unable to read Dot4ReverseReply header: Resource 
temporarily unavailable bytesRead=0 io/hpiod/do
t4.cpp 245
May 18 18:38:37 shed hpiod: invalid DOT4InitReply: cmd=0, result=20 , 
revision=20 io/hpiod/dot4.cpp 329
May 18 18:38:38 shed hp_color_LaserJet_2550_series?serial=00CNHFD04484: INFO: 
open print channel failed; will retry in 30 se
conds...

Having upgraded to CUPS 1.2.0 the USB backend seems to have vanished... I 
can't configure this printer via USB any more (either in localhost:631 or in 
s-c-p) - oh dear!
Comment 8 David Anderson 2006-05-18 13:43:42 EDT
Good thing that this is an HP2550Ln, with the emphasis on n - it has a network 
card. So I can print with the help of my trusty crossover cable.

Is the vanishing of the USB backend a bug or 
feature? /usr/lib/cups/backend/usb still exists, but nothing in s-c-p or 
localhost:631 allows me to access it.
Comment 9 Tim Waugh 2006-05-18 13:51:29 EDT
The USB backend vanishing is actually expected -- when using HPLIP (which uses
libusb) it detaches the kernel usblp driver from that device, since it conflicts
with libusb.  So if you want to use the 'usb' backend you need to disable the
HPLIP service ('/sbin/chkconfig hplip off; /sbin/service hplip stop') and
re-load the kernel usblp driver ('/sbin/rmmod usblp; /sbin/modprobe usblp').

The HPLIP error messages, however, are not expected. ;-)

Investigating..
Comment 10 David Anderson 2006-05-18 16:55:30 EDT
Thanks for the info!

Back in comment #1, it says that printing didn't work with 0.9.8 either. So it 
seems that only the status information is now working - the printing is still 
as broke as before. Similar but not identical message, comparing comments #2 
and #7.

Incidentally, why does Fedora not ship with the proper PPD for this printer? 
It is under a MIT open source license, and enables all the printer's proper 
features which otherwise can't be accessed through the generic postscript 
driver that gets used otherwise. Should I file another bug?
Comment 11 Tim Waugh 2006-05-22 11:28:26 EDT
> Incidentally, why does Fedora not ship with the proper PPD for this printer?

Er.. it does:

/usr/share/foomatic/db/source/PPD/HP/color_laser/HP_Color_LaserJet_2550.ppd.gz

That's what you should be getting when you choose 'HP Color LaserJet 2550' -- if
not, please file a bug against foomatic.
Comment 12 David Anderson 2006-05-23 08:09:43 EDT
Bug filed: #192815
Comment 13 Tim Waugh 2006-12-15 07:44:10 EST
The only response from the HPLIP developers has been:

  Make sure the CLJ2550 has the latest firmware.

:-/

Do you still see this problem?
Comment 14 David Anderson 2006-12-19 15:52:09 EST
Still fails to print with the same errors in the log.

[root@shed ~]# rpm -q cups hplip system-config-printer
cups-1.2.5-1.fc5.4
hplip-1.6.6a-1.1
system-config-printer-0.6.151.8-1

Dec 19 20:48:42 shed hpiod: unable to read Dot4ReverseReply header: Resource 
temporarily unavailable bytesRead=0 io/hpiod/dot4.cpp 245
Dec 19 20:48:42 shed hpiod: invalid DOT4InitReply retrying command... 
io/hpiod/dot4.cpp 332
Dec 19 20:48:46 shed hpiod: unable to read Dot4ReverseReply header: Resource 
temporarily unavailable bytesRead=0 io/hpiod/dot4.cpp 245
Dec 19 20:48:46 shed hpiod: invalid DOT4InitReply: cmd=0, result=20 , 
revision=20 io/hpiod/dot4.cpp 343
Dec 19 20:48:47 shed hp_color_LaserJet_2550_series?serial=00CNHFD04484: INFO: 
open print channel failed; will retry in 30 seconds...

Unfortunately the firmware update tool appears to require Windows... :-(
Comment 15 Tim Waugh 2007-06-11 05:58:03 EDT
Doesn't seem like there's a lot we can do. :-(

Are you still running Fedora Core 5?
Comment 16 David Anderson 2007-06-11 08:38:00 EDT
I have access to a Windows installation now, so will have a look at doing the 
firmware update. On Fedora 6 now, but have downloaded 7 (and have a LiveCD).
Comment 17 Tim Waugh 2007-08-09 08:58:12 EDT
Did the firmware update help?
Comment 18 David Anderson 2007-10-04 07:39:49 EDT
Unfortunately upon booting Windows, I discovered that I can only do the 
firmware using the software on the HP printer driver CD... which I've lost, 
and doesn't seem to be available for a free download.

I note that the hplip package now contains /usr/bin/hp-firmware - might this 
do the trick?

David
Comment 19 Tim Waugh 2007-10-04 08:21:27 EDT
Er.. it might.  It is for updating the firmware, yes.
Comment 20 David Anderson 2007-10-15 11:26:07 EDT
I'm selling the printer, and don't want to risk bricking it by doing a 
firmware update... so I'm not going to be able to try this. I'll have a check 
with the latest hplip to see if it's working in any case.
Comment 21 David Anderson 2007-10-17 18:00:14 EDT
I tried the latest hplip, on F7... it works! I printed!
Comment 22 Tim Waugh 2007-10-19 10:18:14 EDT
Great, thanks for testing.