Bug 1779801

Summary: All nodes go NotReady after 24 hours, several pending CSRs
Product: OpenShift Container Platform Reporter: Maciej Szulik <maszulik>
Component: kube-controller-managerAssignee: Maciej Szulik <maszulik>
Status: CLOSED ERRATA QA Contact: Walid A. <wabouham>
Severity: urgent Docs Contact:
Priority: unspecified    
Version: 4.2.0CC: aos-bugs, brad.ison, deads, dmoessne, gblomqui, jhou, joedward, maszulik, mfojtik, mgugino, mifiedle, obockows, schoudha, scuppett, sdodson, sttts, wabouham, xtian, xxia
Target Milestone: ---Keywords: Regression, Reopened, TestBlocker
Target Release: 4.2.z   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1755469 Environment:
Last Closed: 2019-12-20 00:46:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1755469    
Bug Blocks:    

Comment 2 Xingxing Xia 2019-12-09 02:02:55 UTC
Hi, Walid, this is a clone of original bug 1755469, could you verify it? Thanks in advance.
One interesting thing is 4.2.2 was shown running well in bug 1755469#c42 while above PR is recent.

Comment 5 Walid A. 2019-12-13 05:33:43 UTC
Verified that all nodes are still Ready after 25+ hours on both AWS and Azure IPI installed clusters:

Azure: 

# oc get clusterversion
NAME      VERSION   AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.10    True        False         25h     Cluster version is 4.2.10

# oc get nodes
NAME                                        STATUS   ROLES    AGE   VERSION
walid4210zb-dxzqw-master-0                  Ready    master   26h   v1.14.6+888f9c630
walid4210zb-dxzqw-master-1                  Ready    master   26h   v1.14.6+888f9c630
walid4210zb-dxzqw-master-2                  Ready    master   26h   v1.14.6+888f9c630
walid4210zb-dxzqw-worker-centralus1-kfxzw   Ready    worker   26h   v1.14.6+888f9c630
walid4210zb-dxzqw-worker-centralus2-wrml6   Ready    worker   26h   v1.14.6+888f9c630
walid4210zb-dxzqw-worker-centralus3-csvpq   Ready    worker   26h   v1.14.6+888f9c630


AWS:
# oc get clusterversion
NAME      VERSION   AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.2.10    True        False         25h     Cluster version is 4.2.10

# oc get nodes
NAME                                         STATUS   ROLES    AGE   VERSION
ip-10-0-132-101.us-west-2.compute.internal   Ready    master   26h   v1.14.6+888f9c630
ip-10-0-142-51.us-west-2.compute.internal    Ready    worker   26h   v1.14.6+888f9c630
ip-10-0-157-108.us-west-2.compute.internal   Ready    master   26h   v1.14.6+888f9c630
ip-10-0-157-125.us-west-2.compute.internal   Ready    worker   26h   v1.14.6+888f9c630
ip-10-0-163-205.us-west-2.compute.internal   Ready    master   26h   v1.14.6+888f9c630
ip-10-0-164-109.us-west-2.compute.internal   Ready    worker   26h   v1.14.6+888f9c630

Comment 7 errata-xmlrpc 2019-12-20 00:46:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4181