Bug 1779864

Summary: kubelet needs --reserved-cpus to have fine control over isolation of system resources vs static-cpu pods
Product: OpenShift Container Platform Reporter: Vladik Romanovsky <vromanso>
Component: NodeAssignee: Ryan Phillips <rphillips>
Status: CLOSED ERRATA QA Contact: Sunil Choudhary <schoudha>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 4.4CC: aos-bugs, jokerman
Target Milestone: ---   
Target Release: 4.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-13 21:54:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Vladik Romanovsky 2019-12-04 21:19:39 UTC
Description of problem:

Currently kubeReserved and systemReserved values affect how kubelet sets aside CPUs to not allocate from for static-cpu-manager pods.  These cpus are not under the direct control of the user and may not be predictable which CPUs are used.  Documentation suggests that these CPUs start with 0 and are allocated incrementally, but our observations are that they follow a pattern of 0, 2, etc.

Different systems have different CPU enumeration and may not work well with the assumptions kubelet may make for reserving these CPUs.  We would like to ensure the feature recently merged upstream, --reserved-cpus, is included in OCP as soon as possible.  This provides the administrator the ability to specify exactly which CPUs are not used for static-cpu pods, and then this can be closely coordinated with system tuning options, using those [and only those] CPUs for system tasks.

Comment 4 errata-xmlrpc 2020-05-13 21:54:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581