Bug 1780037

Summary: alertmanager-access role prevents cluster-monitoring-view grantees users to view fired alerts
Product: OpenShift Container Platform Reporter: Sergiusz Urbaniak <surbania>
Component: MonitoringAssignee: Sergiusz Urbaniak <surbania>
Status: CLOSED ERRATA QA Contact: Junqi Zhao <juzhao>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.3.0CC: alegrand, anpicker, erooth, kakkoyun, lcosic, mloibl, pkrupa, surbania
Target Milestone: ---   
Target Release: 4.4.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1780142 (view as bug list) Environment:
Last Closed: 2020-05-04 11:18:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1780142    

Description Sergiusz Urbaniak 2019-12-05 09:47:09 UTC
With introducing the alertmanager-access role (https://jira.coreos.com/browse/SREP-1983) we prevent users having the cluster-monitoring-view cluster role to view fired alerts/silences and any information that reads from alertmanager.

This change is too intrusive and too coarse-grained, so effectively PM (Christian Heidenreich) is voting for undoing that change for 4.3.

Comment 4 errata-xmlrpc 2020-05-04 11:18:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581