Bug 1781104

Summary: Failed pods should not trigger KubePodNotReady
Product: OpenShift Container Platform Reporter: Sergiusz Urbaniak <surbania>
Component: MonitoringAssignee: Sergiusz Urbaniak <surbania>
Status: CLOSED ERRATA QA Contact: Junqi Zhao <juzhao>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.3.0CC: alegrand, anpicker, erooth, juzhao, kakkoyun, lcosic, mloibl, pkrupa, surbania
Target Milestone: ---   
Target Release: 4.3.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1781103 Environment:
Last Closed: 2020-01-23 11:18:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1781103    
Bug Blocks:    

Description Sergiusz Urbaniak 2019-12-09 10:43:08 UTC
+++ This bug was initially created as a clone of Bug #1781103 +++

Upstream tried to fix https://github.com/kubernetes-monitoring/kubernetes-mixin/issues/215 by contributing https://github.com/kubernetes-monitoring/kubernetes-mixin/pull/221.

Unfortunately this is not the right approach and it was reverted in https://github.com/kubernetes-monitoring/kubernetes-mixin/pull/296.

release-4.4 does contain the revert, but release-4.3 doesn't.

Comment 4 errata-xmlrpc 2020-01-23 11:18:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062