Bug 1782447

Summary: The naming rule of cluster name does not match the rule of GCP
Product: OpenShift Container Platform Reporter: Abhinav Dahiya <adahiya>
Component: InstallerAssignee: Abhinav Dahiya <adahiya>
Installer sub component: openshift-installer QA Contact: yangyang <yanyang>
Status: CLOSED ERRATA Docs Contact:
Severity: medium    
Priority: unspecified CC: jiajliu, jialiu, padillon, yanyang
Version: 4.3.0   
Target Milestone: ---   
Target Release: 4.3.0   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1777232 Environment:
Last Closed: 2020-01-23 11:18:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1777232    
Bug Blocks:    

Comment 4 yangyang 2019-12-20 03:44:28 UTC
Verified with payload 4.3.0-0.nightly-2019-12-19-024927


Steps to verify it as below:

# openshift-install create install-config --dir=test
? SSH Public Key /root/.ssh/id_rsa.pub
? Platform gcp
? Project ID openshift-qe
? Region us-central1
? Base Domain qe.gcp.devcluster.openshift.com

X Sorry, your reply was invalid: GCP requires cluster name to match regular expression (?:[a-z](?:[-a-z0-9]{0,61}[a-z0-9])?)
? Cluster Name [? for help] 123456

Comment 6 errata-xmlrpc 2020-01-23 11:18:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062