Bug 1782992

Summary: Unable to boot RHCOS instances on remote libvirtd on s390x
Product: OpenShift Container Platform Reporter: Alex Crawford <crawford>
Component: InstallerAssignee: Alex Crawford <crawford>
Installer sub component: openshift-installer QA Contact: Jeremy Poulin <jpoulin>
Status: CLOSED ERRATA Docs Contact:
Severity: unspecified    
Priority: unspecified CC: jpoulin
Version: 4.3.0   
Target Milestone: ---   
Target Release: 4.3.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1782986
: 1782994 (view as bug list) Environment:
Last Closed: 2020-01-23 11:18:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1782986    
Bug Blocks: 1782994    

Description Alex Crawford 2019-12-12 18:48:57 UTC
+++ This bug was initially created as a clone of Bug #1782986 +++

s390x doesn't support the QEMU firmware config device that we use to pass Ignition configs through to RHCOS guests. As a fallback, libguestfish was used to modify the root disk to directly inject the Ignition config. This doesn't work on remote machines though, so the new approach is to use the RHCOS images built for OpenStack and to pass the Ignition config through the config-drive mechanism instead.

Comment 1 Jeremy Poulin 2019-12-12 20:45:47 UTC
Moving to ON_QA since this is already merged and verified.

Comment 2 Jeremy Poulin 2019-12-12 20:46:32 UTC
Verified by the IBM Z team.
Ji Chen <jichenjc@cn.ibm.com>

Moving it to verified.

Comment 4 errata-xmlrpc 2020-01-23 11:18:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062