Bug 1784200

Summary: TechPreviewExit: Full Support of qdevice heuristics
Product: Red Hat Enterprise Linux 8 Reporter: Chris Feist <cfeist>
Component: corosync-qdeviceAssignee: Chris Feist <cfeist>
Status: CLOSED WONTFIX QA Contact: cluster-qe <cluster-qe>
Severity: unspecified Docs Contact: Steven J. Levine <slevine>
Priority: unspecified    
Version: 8.2CC: blc, jfriesse, phagara, slevine
Target Milestone: rcKeywords: Reopened, TestOnly, Triaged
Target Release: 8.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Technology Preview
Doc Text:
.Heuristics in `corosync-qdevice` available as a Technology Preview Heuristics are a set of commands executed locally on startup, cluster membership change, successful connect to `corosync-qnetd`, and, optionally, on a periodic basis. When all commands finish successfully on time (their return error code is zero), heuristics have passed; otherwise, they have failed. The heuristics result is sent to `corosync-qnetd` where it is used in calculations to determine which partition should be quorate.
Story Points: ---
Clone Of: Environment:
Last Closed: 2021-12-22 07:27:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chris Feist 2019-12-16 23:20:09 UTC
This bug will probably just be a Test-Only bug looking to validate full support of qdevice heuristics.

Comment 1 Jan Friesse 2020-05-14 12:57:51 UTC
This bug is indeed testonly because support for heuristics is in the code for some time already.

Comment 9 RHEL Program Management 2021-06-16 07:30:04 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.

Comment 14 RHEL Program Management 2021-12-22 07:27:03 UTC
After evaluating this issue, there are no plans to address it further or fix it in an upcoming release.  Therefore, it is being closed.  If plans change such that this issue will be fixed in an upcoming release, then the bug can be reopened.