Bug 1784793

Summary: update openshift/opencontainers/runc dependencies
Product: OpenShift Container Platform Reporter: Lukasz Szaszkiewicz <lszaszki>
Component: NodeAssignee: Ryan Phillips <rphillips>
Status: CLOSED ERRATA QA Contact: Weinan Liu <weinliu>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 4.4CC: aos-bugs, jokerman, scuppett, weinliu
Target Milestone: ---   
Target Release: 4.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
: 1806176 (view as bug list) Environment:
Last Closed: 2020-07-13 17:12:48 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1806176    

Description Lukasz Szaszkiewicz 2019-12-18 10:55:44 UTC
As part of 1.17 release, upstream Kubernetes updated its opencontainers/runc dependency in [1].

As a consequence of that upgrade, they renamed `cgroupsystemd.Manager` struct in [2].

Since Openshift uses a fork of opencontainers/runc during the rebase to 1.17 I had to revert the rename in [3] because we miss the commit that introduced the change.

Please add that missing commit to openshift/opencontainers/runc repository. 


[1] https://github.com/kubernetes/kubernetes/pull/83527/commits 
[2]https://github.com/kubernetes/kubernetes/pull/83527/commits/b9cfb193211a85eed34532464ff4e71756d6ae77
[3] https://github.com/openshift/origin/pull/24286

Comment 3 Weinan Liu 2020-03-16 11:10:57 UTC
1.17.0 got rebased in https://github.com/openshift/origin/pull/24286 to add the missing commit

Comment 5 errata-xmlrpc 2020-07-13 17:12:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409