Bug 1787243

Summary: gnome-python2: Remove (sub)packages from Fedora 32+: gnome-python2-canvas, gnome-python2-devel, gnome-python2-gconf, gnome-python2-gnome...
Product: [Fedora] Fedora Reporter: Miro Hrončok <mhroncok>
Component: gnome-python2Assignee: Peter Robinson <pbrobinson>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: caillon+fedoraproject, cstratak, gnome-sig, igor.raits, john.j5live, lbalhar, mclasen, mhroncok, ngompa13, pbrobinson, pviktori, rhughes, rstrode, sandmann, walters, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-01-15 14:33:45 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1737929, 1625773, 1698500, 1708725, 1738126    

Description Miro Hrončok 2020-01-01 21:23:44 UTC
In line with the Retire Python 2 Fedora change [0], the following (sub)packages of gnome-python2 were marked for removal:

 * gnome-python2-canvas
 * gnome-python2-devel
 * gnome-python2-gconf
 * gnome-python2-gnome
 * gnome-python2-gnomevfs

There was no approved FESCo exception for this package.

Please remove them from your package in Rawhide (Fedora 32).

Please don't remove packages from Fedora 31/30/29, removing packages from a released Fedora branch is forbidden and out of scope of this request.

If there is no objection in two weeks, we will remove the package(s) as soon as we get to it. This change might not match your packaging style, so we'd prefer if you did the change. If you need more time, please let us know here.

If you do the change yourself, it would help us a lot by reducing the amount of packages we need to mass change.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

This text is automated. We are sorry if you already communicated with us about this in another place.

[0] https://fedoraproject.org/wiki/Changes/RetirePython2

Comment 1 Miro Hrončok 2020-01-01 21:25:48 UTC
*** Bug 1747854 has been marked as a duplicate of this bug. ***

Comment 2 Miro Hrončok 2020-01-15 14:33:45 UTC
I've retired the package.