Bug 178917
| Summary: | iptables won't start. errors with Too many levels of symbolic links | ||
|---|---|---|---|
| Product: | [Fedora] Fedora | Reporter: | Steven Haigh <netwiz> |
| Component: | iptables | Assignee: | Thomas Woerner <twoerner> |
| Status: | CLOSED DUPLICATE | QA Contact: | Ben Levenson <benl> |
| Severity: | medium | Docs Contact: | |
| Priority: | medium | ||
| Version: | rawhide | Keywords: | Security |
| Target Milestone: | --- | ||
| Target Release: | --- | ||
| Hardware: | i386 | ||
| OS: | Linux | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2006-01-25 14:48:16 UTC | Type: | --- |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
Also, running iptables produces: # iptables -L -n -v ERROR: 0 not a valid target) Aborted |
From Bugzilla Helper: User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7 Description of problem: When trying to load the iptables initscript, the following error is presented. # /etc/init.d/iptables restart Flushing firewall rules: iptables: Too many levels of symbolic links iptables: Too many levels of symbolic links [FAILED] Setting chains to policy ACCEPT: filter iptables: Invalid argument [FAILED] Unloading iptables modules: [ OK ] Applying iptables firewall rules: iptables-restore v1.3.4: Can't set policy `FORWARD' on `ACCEPT' line 21: Bad built-in chain name [FAILED] Filing this under a security issue, as no firewalling can be done on the machine in this state. Also no NAT/filtering. Version-Release number of selected component (if applicable): kernel-2.6.15-1.1871_FC5 iptables-1.3.4-3 How reproducible: Always Steps to Reproduce: 1. Update to latest devel system via yum. 2. Reboot into new kernel 3. Try to start iptables. Actual Results: See Description. Expected Results: iptables should have loaded the firewall rules in /etc/sysconfig/iptables Additional info: