Bug 1789748

Summary: [Kuryr] Cluster destroy command timesout
Product: OpenShift Container Platform Reporter: Luis Tomas Bolivar <ltomasbo>
Component: InstallerAssignee: Luis Tomas Bolivar <ltomasbo>
Installer sub component: OpenShift on OpenStack QA Contact: Jon Uriarte <juriarte>
Status: CLOSED ERRATA Docs Contact:
Severity: low    
Priority: low CC: juriarte, m.andre
Version: 4.3.0   
Target Milestone: ---   
Target Release: 4.3.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1789746 Environment:
Last Closed: 2020-02-19 05:39:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1789746    
Bug Blocks:    

Description Luis Tomas Bolivar 2020-01-10 10:44:28 UTC
+++ This bug was initially created as a clone of Bug #1789746 +++

When using Kuryr SDN the number of resources created on the
OpenStack side is way larger than for the OpenShift SDN case.
For this reason, as there is no specific order for the resources
to be deleted, the chances of the deletion of one resource (e.g.,
a network) being blocked by the deletion of another (e.g. a port
on that network) are higher, thus needing more retries or the
destroy command times out

Comment 2 Jon Uriarte 2020-02-12 08:45:32 UTC
Verified in 4.3.0-0.nightly-2020-02-11-113855 on top of OSP 13 2020-01-15.3.

Cluster deletion works, all the resources are deleted and no time-out is reached.

Comment 4 errata-xmlrpc 2020-02-19 05:39:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0492