Bug 1789903

Summary: "text" x-descriptors (both "specDescriptor" and "statusDescriptor") always shows "None" whenever the data is "True".
Product: OpenShift Container Platform Reporter: Robb Hamilton <rhamilto>
Component: Management ConsoleAssignee: bpeterse
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.2.0CC: aos-bugs, jokerman, spadgett, yanpzhan, yapei
Target Milestone: ---   
Target Release: 4.2.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1780384 Environment:
Version: 4.4.0-0.ci-2019-12-04-051457 Cluster ID: 73e38a63-0543-4277-9bd4-018c287764e8 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:71.0) Gecko/20100101 Firefox/71.0
Last Closed: 2020-01-22 10:46:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1779894, 1780384    
Bug Blocks: 1784870    

Comment 2 Yanping Zhang 2020-01-13 06:28:46 UTC
Checked on ocp 4.2 with payload: 4.2.14
Install Etcd Operator in project, then in CSV add x-descriptor with text value "True" in "specDescriptors" and "statusDescriptors" as below, then create instance, check on detail page, it shows "True" for "Test For Bug" and "Status Test For Bug".
        specDescriptors:
          - description: Test Bug.
            displayName: Test For Bug
            path: cluster.testbug
            value: 'True'
            x-descriptors:
              - 'urn:alm:descriptor:text'
        statusDescriptors:
          - description: Status Test Bug.
            displayName: Status Test For Bug
            path: cluster.statustestbug
            value: 'True'
            x-descriptors:
              - 'urn:alm:descriptor:text'

The bug is fixed, so move it to Verified.

Comment 4 errata-xmlrpc 2020-01-22 10:46:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0107