Bug 1790523

Summary: [4.3] dual-stack config for openshift-apiserver
Product: OpenShift Container Platform Reporter: Dan Winship <danw>
Component: openshift-apiserverAssignee: Michal Fojtik <mfojtik>
Status: CLOSED ERRATA QA Contact: Marius Cornea <mcornea>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 4.3.zCC: aos-bugs, mfojtik, scuppett, xxia
Target Milestone: ---   
Target Release: 4.3.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1790522 Environment:
Last Closed: 2020-02-19 05:39:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1790522    
Bug Blocks:    

Description Dan Winship 2020-01-13 14:34:53 UTC
+++ This bug was initially created as a clone of Bug #1790522 +++

openshift-apiserver should run dual-stack for ipv4/ipv6/dual-stack compat

--- Additional comment from Dan Winship on 2020-01-13 09:34:05 EST ---

Tested in the ipv6 builds. Not currently QA-able.

Comment 2 Xingxing Xia 2020-02-10 10:16:31 UTC
Hi, Dan Winship, saw bug 1790522#c1 comment. Is this bug same like that comment? Thanks

Comment 3 Dan Winship 2020-02-10 15:10:28 UTC
yes, this is another IPv6 one... missed it because I didn't search for "dual-stack", just "ipv6"

Comment 4 Marius Cornea 2020-02-12 02:15:18 UTC
Verified on 4.3.0-0.nightly-2020-02-10-055634-ipv6.3(based on 4.3.0-0.nightly-2020-02-10-055634)

Comment 6 errata-xmlrpc 2020-02-19 05:39:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0492