Bug 1791495

Summary: Foreman-rake facts:cleanup batch/rolling support
Product: Red Hat Satellite Reporter: Mike McCune <mmccune>
Component: FactAssignee: Lukas Zapletal <lzap>
Status: CLOSED ERRATA QA Contact: Radovan Drazny <rdrazny>
Severity: unspecified Docs Contact:
Priority: high    
Version: 6.6.0CC: cmarinea, egolov, mhulan, mjia, mmccune, pcreech
Target Milestone: 6.6.2Keywords: PrioBumpField, Triaged
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: foreman-1.22.0.34-1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1773133 Environment:
Last Closed: 2020-02-13 14:59:35 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Comment 3 Bryan Kearney 2020-01-16 01:02:51 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/25227 has been resolved.

Comment 5 Radovan Drazny 2020-02-11 17:28:13 UTC
Tested with Sat 6.6.2 Snap 1.
# foreman-rake facts:clean --trace --verbose
** Invoke facts:clean (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute facts:clean
Starting orphaned facts clean up
Finished, cleaned 34999 facts

No issues, no error in logs cleaning the facts.

Comment 7 errata-xmlrpc 2020-02-13 14:59:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0496