Bug 1791730

Summary: [4.3] ipv6 backports for origin
Product: OpenShift Container Platform Reporter: Dan Winship <danw>
Component: NetworkingAssignee: Dan Winship <danw>
Networking sub component: ovn-kubernetes QA Contact: Marius Cornea <mcornea>
Status: CLOSED ERRATA Docs Contact:
Severity: unspecified    
Priority: unspecified CC: xtian, zzhao
Version: 4.3.zKeywords: Reopened
Target Milestone: ---   
Target Release: 4.3.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1791726 Environment:
Last Closed: 2020-03-10 23:52:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1791726    
Bug Blocks:    

Description Dan Winship 2020-01-16 12:01:13 UTC
+++ This bug was initially created as a clone of Bug #1791726 +++

Origin master needs the "kubelet --node-ip ::" backport.

Origin 4.3 needs both that and the "kube-apiserver --bind-address ::" fix that is already in master.

--- Additional comment from Dan Winship on 2020-01-16 07:00:24 EST ---

verified in ipv6 testing

Comment 2 zhaozhanqi 2020-02-12 11:52:55 UTC
hi, Marius Cornea 
this bug also need ipv6 cluster for 4.3.z. So assigned this bug to you according to https://bugzilla.redhat.com/show_bug.cgi?id=1792309#c6
assign this bug to you . please back to me if I'm wrong.

Comment 3 zhaozhanqi 2020-02-13 11:46:26 UTC
no regression bugs found in 4.3.z when the PR merged. move this bug to close

Comment 5 Marius Cornea 2020-02-27 20:49:11 UTC
On an ipv6 bare metal setup:

[root@master-0 core]# ps axu | grep kubelet
root        3087 12.2  0.8 3884664 280360 ?      Ssl  19:42   8:00 /usr/bin/hyperkube kubelet --config=/etc/kubernetes/kubelet.conf --bootstrap-kubeconfig=/etc/kubernetes/kubeconfig --kubeconfig=/var/lib/kubelet/kubeconfig --container-runtime=remote --container-runtime-endpoint=/var/run/crio/crio.sock --node-labels=node-role.kubernetes.io/master,node.openshift.io/os_id=rhcos --node-ip=fd2e:6f44:5dd8:c956::136 --address=fd2e:6f44:5dd8:c956::136 --minimum-container-ttl-duration=6m0s --cloud-provider= --volume-plugin-dir=/etc/kubernetes/kubelet-plugins/volume/exec --v=3

Comment 8 errata-xmlrpc 2020-03-10 23:52:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0676