Bug 1792474

Summary: Systemd presets for user units
Product: [Fedora] Fedora Reporter: Ben Cotton <bcotton>
Component: Changes TrackingAssignee: Zbigniew Jędrzejewski-Szmek <zbyszek>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 32CC: bcotton, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: systemd-245~rc1-2.fc32 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-04-28 14:30:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ben Cotton 2020-01-17 17:04:23 UTC
This is a tracking bug for Change: Systemd presets for user units
For more details, see: https://fedoraproject.org/wiki/Changes/Systemd_presets_for_user_units

System units are managed through presets since F18 and by policy, presets are carried by the fedora-release package. This policy is now extended to user units.

Comment 1 Zbigniew Jędrzejewski-Szmek 2020-02-10 16:43:00 UTC
The changes in systemd and fedora-release and packaging guidelines are done. If some units are not
enabled after installation and they should be, they most likely need to be added to fedora-release.
Please comment here if you see any.

Comment 2 Ben Cotton 2020-02-11 18:13:46 UTC
Branching Fedora 32 Changes from rawhide. Today is the Code Complete (testable) deadline. Please make sure your bug status is set appropriately:

Complete (testable) -> MODIFIED
Complete (100% code complete) -> ON_QA (deadline is 25 February)

If you need to defer this change until Fedora 33, please set the version back to 'rawhide'.

Comment 3 Ben Cotton 2020-02-28 16:31:41 UTC
The Code Complete (100% Complete) deadline has passed. If your Change is 100% complete, please set the status of this bug to ON_QA. If you need to defer to Fedora 33, please set the version to rawhide. A list of incomplete changes is being submitted to FESCo for review.

Comment 4 Ben Cotton 2020-04-28 14:30:21 UTC
Fedora 32 is released!